summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2019-06-15 00:22:39 +0200
committerDavid Runge2019-06-15 00:22:39 +0200
commit74692c1233eaf2aff2771970269ea951c0d7b3f6 (patch)
treebafe7cb5083d30b64ec2e993adf34dfa55bc0b09 /PKGBUILD
parente7d2d0ef14f171a269e8a0bbe20815981052accd (diff)
downloadaur-74692c1233eaf2aff2771970269ea951c0d7b3f6.tar.gz
PKGBUILD: Upgrading to 2.21.1. Adding sysusers and uwsgi integration. Removing useless optdepends (web servers).
mantisbt.tmpfiles: Adding /run/mantisbt, owned by user/group mantisbt. mantisbt.install: Updating informational printout about requiring separate user. mantisbt.uwsgi: Adding uWSGI integration. mantisbt.sysusers: Adding separate user/group mantisbt.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9a087d7f2d2..52746f92406a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,14 @@
# Contributor: Angel 'angvp' Velasquez <angvp@archlinux.com.ve>
pkgname=mantisbt
-pkgver=2.21.0
+pkgver=2.21.1
pkgrel=1
pkgdesc='Web-based issue tracking system'
arch=('any')
url='https://www.mantisbt.org/'
license=('GPL2')
depends=('php')
-optdepends=('apache: run in webserver'
- 'curl: interface Twitter'
- 'lighttpd: run in webserver'
+optdepends=('curl: interface Twitter'
'mariadb: use local MySQL server'
'php-fpm: run in fastCGI process manager'
'php-gd: generate captcha'
@@ -26,12 +24,15 @@ backup=('etc/webapps/mantisbt/config_inc.php'
'etc/webapps/mantisbt/custom_strings_inc.php'
'etc/webapps/mantisbt/custom_relationships_inc.php'
'etc/webapps/mantisbt/custom_functions_inc.php'
- 'etc/webapps/mantisbt/custom_constants_inc.php'
-)
+ 'etc/webapps/mantisbt/custom_constants_inc.php')
source=("https://downloads.sourceforge.net/project/${pkgname}/mantis-stable/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'tmpfiles.conf')
-sha512sums=('c93044cb49f1ed5cc7abd91b16cef3ead4844c0b869026db174372268c002b6ba3a3e79ccb723be569665740063071fe92165f0fc0286a5cdabdf84be0ab1486'
- 'e0c3fc92a3a61f86f780e5e30ccefe751ef0f16727a44006f8c7dae53951abaa0b8c6e0dc3e807668e0fe78252296996a6123cc5d5bf8427055ae07efe3bd37e')
+ "${pkgname}.sysusers"
+ "${pkgname}.tmpfiles"
+ "${pkgname}.uwsgi")
+sha512sums=('cc7f9c46a55753e08ddde6c351139f6c8f77fd23e35ffc2668fbe393d80054138442d6db3cfde1087ee52ce1a4441661aaa1f3acdd1ea1d718b31a6b86144bf8'
+ '3fd4e7faad7774892abfd20006ae3efcd7b0ba315447da9cea8d7352d5fd1e7f0c558d3855ad4e667a0bfe6ae0d95d12c848a78d53312521a7f551f2edca723e'
+ 'b1b9145d1ba423055d5e45734a9d74c639b75ae5b5d580024b50626332a74830dd39b976de590549ff1c47c400ba4e1c20b27b69fb140f7d8527d8d281d0c7bd'
+ '1b36d8956986360306eb15a9279c54eba46e74dfe0623dc26b3be3e8f409ab4f0afe6b34a9001cbeb9f33452fec5ccc8089a53352fa885894cc262ca9c12bc39')
install="${pkgname}.install"
prepare() {
@@ -61,8 +62,15 @@ package() {
done
# readme
install -vDm 644 readme.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
- # tmpfiles.d integration
- install -vDm 644 ../tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ # tmpfiles.d
+ install -vDm 644 "../${pkgname}.tmpfiles" \
+ "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ # sysusers.d
+ install -vDm 644 "../${pkgname}.sysusers" \
+ "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ # uWSGI
+ install -vDm 644 "../${pkgname}.uwsgi" \
+ "${pkgdir}/etc/uwsgi/${pkgname}.ini"
}
# vim: ts=2 sw=2 et: