summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2019-04-30 18:04:04 +0200
committerDavid Runge2019-04-30 18:04:04 +0200
commite7d2d0ef14f171a269e8a0bbe20815981052accd (patch)
treea89251dacc41780e08531cb64b59fe55f41c02d0 /PKGBUILD
parent4996f950836dc1a1110e0c7186e4384fcf4a5161 (diff)
downloadaur-e7d2d0ef14f171a269e8a0bbe20815981052accd.tar.gz
PKGBUILD: Upgrading to 2.21.0. General cleanup and simplification of build script. Fixing optdepends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 26 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4881f16d4762..a9a087d7f2d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,22 @@
# Contributor: Angel 'angvp' Velasquez <angvp@archlinux.com.ve>
pkgname=mantisbt
-pkgver=2.19.0
+pkgver=2.21.0
pkgrel=1
pkgdesc='Web-based issue tracking system'
arch=('any')
url='https://www.mantisbt.org/'
-license=('GPL')
+license=('GPL2')
depends=('php')
-optdepends=('apache: Web server to run MantisBT'
- 'curl: Twitter integration'
- 'gd: Graphs support'
- 'lighttpd: Web server to run MantisBT'
- 'mariadb: SQL database'
- 'nginx: Web server to run MantisBT'
- 'php-pgsql: PostgreSQL database'
- 'uwsgi: Application server to run MantisBT')
+optdepends=('apache: run in webserver'
+ 'curl: interface Twitter'
+ 'lighttpd: run in webserver'
+ 'mariadb: use local MySQL server'
+ 'php-fpm: run in fastCGI process manager'
+ 'php-gd: generate captcha'
+ 'php-pgsql: use PostgreSQL database backend'
+ 'postgresql: use local PostgreSQL database'
+ 'uwsgi: run as application container')
backup=('etc/webapps/mantisbt/config_inc.php'
'etc/webapps/mantisbt/custom_strings_inc.php'
'etc/webapps/mantisbt/custom_relationships_inc.php'
@@ -29,44 +30,37 @@ backup=('etc/webapps/mantisbt/config_inc.php'
)
source=("https://downloads.sourceforge.net/project/${pkgname}/mantis-stable/${pkgver}/${pkgname}-${pkgver}.tar.gz"
'tmpfiles.conf')
-sha512sums=('5d074bc3605a9aae3c4b738e0ea667c3687e97a04e2702941158301ab9c86c14e8bc83fe8d5b9d34d5d011f5b5041d37b1bd44ea40815c2d1ae91f6130b5a987'
+sha512sums=('c93044cb49f1ed5cc7abd91b16cef3ead4844c0b869026db174372268c002b6ba3a3e79ccb723be569665740063071fe92165f0fc0286a5cdabdf84be0ab1486'
'e0c3fc92a3a61f86f780e5e30ccefe751ef0f16727a44006f8c7dae53951abaa0b8c6e0dc3e807668e0fe78252296996a6123cc5d5bf8427055ae07efe3bd37e')
install="${pkgname}.install"
prepare() {
cd "${pkgname}-${pkgver}"
+ # create customization files
+ touch "${srcdir}/custom_"{constants,functions,relationships,strings}_inc.php
find . -type f -exec chmod -c 0644 {} \;
find . -type d -exec chmod -c 0755 {} \;
+ # remove useless scripts
+ find "vendor" -type f -iname "*.py" -delete
}
package() {
cd "${pkgname}-${pkgver}"
- install -vdm 755 "${pkgdir}"/{etc/webapps,usr/share/webapps}/"${pkgname}"
-
# configuration
install -vDm 644 config/config_inc.php.sample \
"${pkgdir}/etc/webapps/${pkgname}/config_inc.php"
- # create customization files
- touch "${pkgdir}/etc/webapps/${pkgname}"/custom_{strings,relationships,functions,constants}_inc.php
-
- # readme
- install -vDm 644 readme.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
-
+ install -vDm 644 ${srcdir}/*.php -t "${pkgdir}/etc/webapps/${pkgname}"
+ # web application
+ install -vdm 755 "${pkgdir}/usr/share/webapps/${pkgname}"
cp -av --no-preserve='ownership' ../${pkgname}-${pkgver}/* \
"${pkgdir}/usr/share/webapps/${pkgname}"
-
- # symlink configuration and configuration
- ln -sv "/etc/webapps/${pkgname}/config_inc.php" \
- "${pkgdir}/usr/share/webapps/${pkgname}/config/config_inc.php"
- ln -sv "/etc/webapps/${pkgname}/custom_strings_inc.php" \
- "${pkgdir}/usr/share/webapps/${pkgname}/config/custom_strings_inc.php"
- ln -sv "/etc/webapps/${pkgname}/custom_relationships_inc.php" \
- "${pkgdir}/usr/share/webapps/${pkgname}/config/custom_relationships_inc.php"
- ln -sv "/etc/webapps/${pkgname}/custom_functions_inc.php" \
- "${pkgdir}/usr/share/webapps/${pkgname}/config/custom_functions_inc.php"
- ln -sv "/etc/webapps/${pkgname}/custom_constants_inc.php" \
- "${pkgdir}/usr/share/webapps/${pkgname}/config/custom_constants_inc.php"
-
+ # symlink configuration and customization
+ for config in {config,custom_{constants,functions,relationships,strings}}_inc.php ;do
+ ln -sv "/etc/webapps/${pkgname}/${config}" \
+ "${pkgdir}/usr/share/webapps/${pkgname}/config/${config}"
+ done
+ # readme
+ install -vDm 644 readme.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
# tmpfiles.d integration
install -vDm 644 ../tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}