summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2016-08-20 22:17:43 +0200
committerMaxime Gauduin2016-08-20 22:18:51 +0200
commitfd9c1e837b6ccf980b2d760684614b51f76d5a8f (patch)
tree8dbac63cca0cb5fdf60479bd18d7e876563ebd12 /PKGBUILD
downloadaur-fd9c1e837b6ccf980b2d760684614b51f76d5a8f.tar.gz
Move from [community] to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65dfdeabc6eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 183866 2016-07-23 11:02:59Z alucryd $
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Alexander 'gridcol' Griesbaum <agrsbm@gmail.com>
+# Contributor: Ravenman <correo.cuervo@gmail.com>
+# Contributor: Anton Bazhenov <anton.bazhenov@gmail>
+# Contributor: Angel 'angvp' Velasquez <angvp@archlinux.com.ve>
+
+pkgname=mantisbt
+pkgver=1.3.0
+pkgrel=2
+pkgdesc='Web-based issue tracking system'
+arch=('any')
+url='http://www.mantisbt.org/'
+license=('GPL')
+depends=('php')
+optdepends=('apache: Web server to run MantisBT'
+ 'curl: Twitter integration'
+ 'gd: Graphs support'
+ 'lighttpd: Web server to run MantisBT'
+ 'mariadb: SQL database'
+ 'nginx: Web server to run MantisBT'
+ 'php-pgsql: PostgreSQL database')
+backup=('etc/webapps/mantisbt/config_inc.php')
+install='mantisbt.install'
+source=("http://downloads.sourceforge.net/mantisbt/mantisbt-${pkgver}.tar.gz")
+sha256sums=('a223107ba9cf1a6a555031f662e81a297133ee9d88896704c689cea15506e2cc')
+
+package() {
+ install -dm 755 "${pkgdir}"/{etc/webapps/mantisbt,usr/share/webapps}
+ cp -dr --no-preserve='ownership' mantisbt-${pkgver} "${pkgdir}"/usr/share/webapps/mantisbt
+
+ ln -s /etc/webapps/mantisbt/config_inc.php "${pkgdir}"/usr/share/webapps/mantisbt/config_inc.php
+ cp "${pkgdir}"/usr/share/webapps/mantisbt/config/config_inc.php.sample "${pkgdir}"/etc/webapps/mantisbt/config_inc.php
+
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -exec chmod 644 {} +
+ chown http:http -R "${pkgdir}"/usr/share/webapps/mantisbt
+}
+
+# vim: ts=2 sw=2 et: