summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFritzOnFire2019-11-21 20:54:59 +0200
committerFritzOnFire2019-11-21 20:54:59 +0200
commit9142c91354acd56cd8bb28579ce7a1fc8267c6ac (patch)
treea3e3de016c5cddd8c8eb3357c0818b3b915f4742 /PKGBUILD
parent313c391729737b186d71329134ad6e703a9612b3 (diff)
downloadaur-9142c91354acd56cd8bb28579ce7a1fc8267c6ac.tar.gz
Fixes proj plugin being ignored
Removes boot version limits (until it breaks again) Updated package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f967eef34af3..350ee97f3959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mapnik-git
_pkgname=mapnik
-pkgver=3.0.20.1046.gfdf60044c
+pkgver=3.0.22.1073.g94dd75666
pkgrel=1
pkgdesc="Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)"
arch=('i686' 'x86_64')
@@ -26,7 +26,7 @@ optdepends=('libxslt: Web Map Service'
'mod_wsgi2: Web Map Service')
makedepends=('scons' 'boost' 'git')
conflicts=('mapnik')
-provides=('mapnik=3.0.20')
+provides=('mapnik=3.0.22')
options=(staticlibs)
install="mapnik.install"
source=("git+https://github.com/mapnik/mapnik.git")
@@ -35,7 +35,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- echo "3.0.20$(git describe --long | cut -c8- | sed 's/-/./g')"
+ echo "3.0.22$(git describe --long | cut -c8- | sed 's/-/./g')"
}
prepare() {
@@ -51,8 +51,9 @@ build() {
PREFIX="/usr" \
INPUT_PLUGINS=all \
DESTDIR="$pkgdir" \
+ FREETYPE_INCLUDES=/usr/include/freetype2 \
FREETYPE_LIBS=/usr/lib \
- FREETYPE_INCLUDES=/usr/include/freetype2
+ CUSTOM_DEFINES="-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1"
}
package(){