summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Hummel2024-01-08 10:28:09 -0700
committerDavid Hummel2024-01-08 10:28:09 -0700
commitc0c74f7e48f826e78b61860897a17ae886377afb (patch)
tree7f63245bfc6e123018a1c3fb5e381ca5165b1aa8 /PKGBUILD
parent77628c452677574b8a4f21c40f2f268799ba6442 (diff)
downloadaur-c0c74f7e48f826e78b61860897a17ae886377afb.tar.gz
Use system sparsehash package and remove bundling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30aa427e9c75..cdd3a05ff819 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mapnik-git
pkgver=4.0.0.r13808.g2e1b325
-pkgrel=2
+pkgrel=3
pkgdesc='Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)'
arch=('i686' 'x86_64')
url='https://github.com/mapnik/mapnik'
@@ -34,14 +34,17 @@ makedepends=('boost'
'git'
'mapbox-geometry.hpp'
'mapbox-polylabel'
- 'mapbox-variant')
+ 'mapbox-variant'
+ 'sparsehash')
conflicts=('mapnik')
provides=('mapnik')
source=('git+https://github.com/mapnik/mapnik.git'
'mapnik-datasource-ogr-test.patch'
+ 'mapnik-use-system-sparsehash.patch'
'git+https://github.com/mapnik/test-data.git')
sha256sums=('SKIP'
'3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52'
+ 'dabb1b99540a6df86b34511d0d94ef505f706419b7e6d1d69314797ebcdce72f'
'SKIP')
pkgver() {
@@ -52,6 +55,7 @@ pkgver() {
prepare() {
cd mapnik || exit
patch -Np1 < ../mapnik-datasource-ogr-test.patch
+ patch -Np1 < ../mapnik-use-system-sparsehash.patch
git submodule init \
test/data
git config submodule.test/data.url "$srcdir"/test-data
@@ -61,6 +65,8 @@ prepare() {
build() {
cmake -B mapnik_build -S mapnik \
+ -DBUILD_BENCHMARK:BOOL=OFF \
+ -DBUILD_DEMO_CPP:BOOL=OFF \
-DBUILD_DEMO_VIEWER:BOOL=OFF \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
@@ -77,11 +83,14 @@ check() {
}
package(){
+ # Remove bundled dejavu fonts from cmake_install.cmake in favor of 'ttf-dejavu' package
+ sed -i '/dejavu-fonts-ttf-2.37/d' "$srcdir"/mapnik_build/cmake_install.cmake
+
+ # Remove bundled sparsehash directory in favor of 'sparsehash' package
+ rm -rf "$srcdir"/mapnik/deps/mapnik/sparsehash
+
DESTDIR="$pkgdir" cmake --install mapnik_build --strip
# License
install -Dm644 "$srcdir"/mapnik/COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
-
- # Remove bundled fonts in favor of those from 'ttf-dejavu'
- rm -rf "$pkgdir"/usr/share/fonts
}