summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMathias Walters2019-03-18 02:15:28 -0400
committerMathias Walters2019-03-18 02:15:28 -0400
commit8463d2e12a35c74e2a9f673a1bb1bdb06b471990 (patch)
treecef0a66e15a9e92988f07b648e62de96b17bac24 /PKGBUILD
downloadaur-8463d2e12a35c74e2a9f673a1bb1bdb06b471990.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c30b1a7c28a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mathias Walters <waltersm at protonmail dot com>
+
+pkgname=maptool-stable-bin
+pkgver=1.4.1.8
+pkgrel=1
+pkgdesc="The stable release of an open source virtual tabletop program"
+arch=('x86_64')
+url="https://rptools.net/tools/maptool"
+license=('AGPL3')
+provides=('maptool')
+conflicts=('maptool')
+source=("https://download.rptools.net/zip/maptool-linux64-${pkgver}.tar" "MapTool.desktop")
+sha256sums=('e0a96e7349db16d2553ec976d2db8f810a3fa4b5b4ba4c22aee5e609e10ff15b' '524c13b4ebdbc392255c1fc7dbb112ab4bb9898186871fa23b3dab1c1edd16bd')
+
+package() {
+
+ tar -C "${pkgdir}" -xf maptool-linux64-${pkgver}.tar
+
+ install -Dm755 "${pkgdir}/MapTool-linux64-offline" "${pkgdir}/usr/bin/MapTool-linux64-offline"
+ install -Dm644 "$srcdir/MapTool.desktop" "${pkgdir}/usr/share/applications/MapTool.desktop"
+
+}