summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-06-19 11:45:39 +0300
committerCaleb Maclennan2020-06-19 11:45:39 +0300
commitfc346d37be2ff888ff62c32a2578d3fdba5a418d (patch)
tree9eacb49b18fb7e8c18df04587fc4d5be9dc1fc1e /PKGBUILD
parentf5aef984cc6159017c8e0b85a90c97aeea1da284 (diff)
downloadaur-fc346d37be2ff888ff62c32a2578d3fdba5a418d.tar.gz
Downgrade Electron to 7
Upstream actually has 8.x, but Arch has 7 or 9 in [community]. Building under 9 works, but I get an infinite loading spinner. 7 works and is functional, so posting with that until we either get a build of 9 that works or spin up AUR packaging for 8.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45f8f0e4ea53..3fadf3de92d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=marktext
pkgver=0.16.2
-pkgrel=1
+pkgrel=2
pkgdesc='A simple and elegant open-source markdown editor that focused on speed and usability'
arch=('x86_64')
url='https://marktext.app'
license=('MIT')
-depends=('electron'
+depends=('electron7'
'libxkbfile'
'libsecret'
'ripgrep')
@@ -25,11 +25,11 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/marktext/marktext/archive/v
"$pkgname.sh"
"$pkgname-arg-handling.patch")
sha256sums=('d39f3d4c3008cacdcefbe6ad9e1e19d803d3c619106878c75f8a5cc38254597c'
- 'c5af6eabe525af458df2ccfac6098092746dd0ae23225c131100bb6e37170f86'
+ '15a964fcc3f6bd7bf1c03566d35201032aecde994446533cad1f810e9b880f14'
'c754a1cad52d10a38eeddb9293ce0a4540296c6adbb47eb5311eaaeded150a01')
-_electronDist=$(dirname $(realpath $(which electron)))
-_electronVersion=$(electron --version | sed -e 's/^v//')
+_electronDist=$(dirname $(realpath $(which electron7)))
+_electronVersion=$(electron7 --version | sed -e 's/^v//')
prepare() {
cd "$pkgname-$pkgver"