summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-07-26 15:09:08 +0200
committerCarsten Teibes2015-07-26 15:10:52 +0200
commite0646ad0205e2b7f8b9fee68d08634b4dbb20cf7 (patch)
treef5faba7f9b1772cb92ade5b0be6e5ebc3b2d2687 /PKGBUILD
parent4f6850d982e09d78793e115dcb51be79e2b0b5d0 (diff)
downloadaur-e0646ad0205e2b7f8b9fee68d08634b4dbb20cf7.tar.gz
[fix] Add patch to remove glu dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1361f1cd8b36..a75f4888261a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=mars-shooter-git
-pkgver=0.7.4.r4.d88244b
+pkgver=0.7.4.r7.c855d04
pkgrel=1
pkgdesc="A ridiculous space shooter with nice graphics (development version)"
arch=('i686' 'x86_64')
@@ -15,11 +15,13 @@ provides=('mars-shooter')
conflicts=('mars-shooter')
source=(mars-shooter::"git+https://github.com/thelaui/M.A.R.S..git"
mars-fribidi.patch
- mars-shader.patch
+ mars-shader.patch::"https://github.com/thelaui/M.A.R.S./pull/2.patch"
+ mars-noglu.patch::"https://github.com/thelaui/M.A.R.S./pull/17.patch"
mars-archinstall.patch)
sha256sums=('SKIP'
'6fb105bd6c7f0b3c35bedc13240e1b1f9ad37bb5b4b1328438532b4f40e19c6e'
- '3f9b15350fb9a3acf05469e6bb2a83ff7fc7113499098d11dc759c343c459afa'
+ '2cb61532d94eb68100ddf24888c513a06ef44c32fc867a3b20dfd901d0a0b1d2'
+ '729fb013fe4ad95e2a15e59bf1ce94eddc3fc42f942253522a9e7b041e052664'
'd33d6cd40bf6b2846c069524ed3344e2f4c3afe373e89c74d3e4888d63e2261a')
pkgver() {
@@ -37,10 +39,12 @@ prepare() {
# add include dir of fribidi
patch -Np1 < ../mars-fribidi.patch
# fix use of sfml2 shader
- patch -Np0 < ../mars-shader.patch
+ patch -Np1 < ../mars-shader.patch
+ # remove glu dependency
+ patch -Np1 < ../mars-noglu.patch
# fix install target
patch -Np0 < ../mars-archinstall.patch
- # fix executable name in and remove mimetype from launcher, todo: use setconf
+ # fix executable name in and remove mimetype from launcher
sed 's/Exec=mars$/&-shooter/;/MimeType=.*/d' -i resources/mars.desktop
}