summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2022-04-10 22:00:48 +0300
committerIgor Dyatlov2022-04-10 22:00:48 +0300
commit9e9ad45e185a117a34f15c79a8d18779b9a1db58 (patch)
tree009b61846d3f2f03d9555c351b97d703a8a2f543 /PKGBUILD
parent34eaed1618f381330ab5b584e32e0f58c229b295 (diff)
downloadaur-9e9ad45e185a117a34f15c79a8d18779b9a1db58.tar.gz
Updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 715c27c89a00..c2d7febd162e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=master-key-git
-pkgver=1.2.0.r1.g345c41b
+pkgver=1.3.0.r2.g4d6c44e
pkgrel=1
-pkgdesc="Master Key is a password manager application built with Python 3 and GTK that generates and manages passwords without the need to store them"
+pkgdesc="A password manager application"
arch=('any')
url="https://gitlab.com/guillermop/master-key"
license=('GPL3')
-depends=('gtk4' 'glib2' 'libadwaita' 'sassc' 'libsass' 'python' 'python-gobject' 'libpwquality' 'sqlcipher' 'tcl')
+depends=('glib2' 'libadwaita' 'python-gobject' 'libpwquality' 'sqlcipher' 'tcl')
makedepends=('git' 'meson' 'gobject-introspection')
+checkdepends=('appstream-glib' 'desktop-file-utils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+$url.git)
-sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -23,16 +24,18 @@ pkgver() {
}
build() {
- arch-meson "${pkgname%-git}" _build
- meson compile -C _build
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
}
+#check() {
+# meson test -C build
+#}
+
package() {
- cd "$srcdir"
- DESTDIR="$pkgdir" ninja install -C _build
+ meson install -C build --destdir "$pkgdir"
}
-