summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-08-29 16:54:52 -0400
committerJean Lucas2018-08-29 17:02:18 -0400
commit114216e80a4ce31b1794d03e28d6f252fdaaa617 (patch)
tree5183fea5fba3fbc67e86126daaa73622222d3574 /PKGBUILD
parente3b2033d67e6e04b1d07bbc4807ef122a8f6c573 (diff)
downloadaur-114216e80a4ce31b1794d03e28d6f252fdaaa617.tar.gz
Modify dependencies
- Add 'git' to makedepends as its required during build - 'npm' is a makedepend to prevent yarn from arbitrarily changing the working directory and causing build failures by being unable to find '.yarnclean'. See https://github.com/tootsuite/mastodon/issues/6809 - Change 'yarn' to be a full dependency so database migrations and asset precompilations don't fail
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d205b7179e78..3ce97594ba9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mastodon
pkgver=2.4.5
-pkgrel=1
+pkgrel=2
pkgdesc='Free software social-network server based on ActivityPub and OStatus'
arch=(i686 x86_64)
url=https://joinmastodon.org
@@ -16,8 +16,9 @@ depends=(ffmpeg
postgresql
redis
ruby-bundler
- protobuf)
-makedepends=(yarn python2)
+ protobuf
+ yarn)
+makedepends=(git npm python2)
conflicts=(mastodon-git)
backup=(etc/mastodon/environment)
install=mastodon.install
@@ -39,7 +40,7 @@ build() {
}
package() {
- install -d "$pkgdir"{/var/lib,/etc/mastodon}
+ install -d "$pkgdir"/{var/lib,etc/mastodon}
cp -a mastodon-$pkgver "$pkgdir"/var/lib/mastodon
ln -s /etc/mastodon/environment "$pkgdir"/var/lib/mastodon/.env
touch "$pkgdir"/etc/mastodon/environment