summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorliolok2020-04-04 21:43:49 +0800
committerliolok2020-04-04 21:43:49 +0800
commit4a44cb7cb003d9d42b1fba4dbe2f3b3740cc2188 (patch)
tree226c5d64d1247639f64d1962c568b9baae242a70 /PKGBUILD
parent880e26611a1134d5f8f4bb4bc16e5d8a67736ec5 (diff)
downloadaur-4a44cb7cb003d9d42b1fba4dbe2f3b3740cc2188.tar.gz
upgrade to v3.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a296c476a290..29b9f6442020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Fredrick Brennan <copypaste@kittens.ph>
pkgname=mastodon
-pkgver=3.0.1
-pkgrel=2
+pkgver=3.1.2
+pkgrel=1
pkgdesc='Self-hosted social media and network server based on ActivityPub and OStatus'
arch=(x86_64)
url=https://joinmastodon.org
@@ -16,13 +16,13 @@ depends=(ffmpeg
libxml2
libxslt
libyaml
- nodejs
+ nodejs-lts-erbium
postgresql
redis
ruby-bundler
protobuf
yarn
- zlib)
+ zlib)
makedepends=(npm)
backup=(etc/mastodon.conf)
install=mastodon.install
@@ -30,7 +30,7 @@ source=(https://github.com/tootsuite/mastodon/archive/v$pkgver.tar.gz
mastodon.target
mastodon.sysusers.d
mastodon.tmpfiles.d)
-sha512sums=('d4a971551683982fffb276738abf25b3b1a81ad81f574232f25116e23221832ce0cc19d83902b5e6b1953be1dc63be0aeff1e634a23ee6d0b3113f36a9b28d2a'
+sha512sums=('9c5e12fb0d46024d41f03f976a21cacf938285db93f1311a5bc2db1d703bc2ed675b39403fd87878a0632338c49bf88395c77d6809ad91b94bc6533f7d89e324'
'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb'
'4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a'
'73493680845e690d0cfd769fbbe68978c0a615602375078aea945ca1f1011404eb4b64972aec7a6e5efa720fb425d91b3f30025391c38ccf77e070ccb391e710')
@@ -43,13 +43,17 @@ prepare() {
# Allow use of higher Node minor versions
sed -i 's/"node": "/&^/' package.json
+
+ # Fix `sidekiq-unique-jobs` 6.0.18 has been yanked
+ sed -i 's/6\.0\.18/6\.0\.21/' Gemfile.lock
}
build() {
cd mastodon-$pkgver
+ bundle config set deployment 'true'
+ bundle config set without 'development test'
bundle install \
- -j$(getconf _NPROCESSORS_ONLN) \
- --deployment --without development test
+ -j$(getconf _NPROCESSORS_ONLN)
yarn install --pure-lockfile
}
@@ -61,7 +65,7 @@ package() {
touch "$pkgdir"/etc/mastodon.conf
ln -s /etc/mastodon.conf "$pkgdir"/var/lib/mastodon/.env.production
ln -s /usr/bin/node "$pkgdir"/var/lib/mastodon/node
-
+
install -Dm 644 mastodon.target -t "$pkgdir"/usr/lib/systemd/system
install -Dm 644 mastodon.sysusers.d "$pkgdir"/usr/lib/sysusers.d/mastodon.conf
install -Dm 644 mastodon.tmpfiles.d "$pkgdir"/usr/lib/tmpfiles.d/mastodon.conf