summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-08-06 23:22:32 -0400
committerJean Lucas2018-08-06 23:27:07 -0400
commit955114a336431192b72f1cc57b3da752b0f8b7f6 (patch)
tree6a4b4493a44b117cd779f1f857aad9c44b6580a1 /PKGBUILD
parentac69ea2e27f6acde3459745d0c94c5c73bf6f10c (diff)
downloadaur-955114a336431192b72f1cc57b3da752b0f8b7f6.tar.gz
Version bump to 2.4.3, routine cleanup
- Correct license - Remove optdepend of sudo since install file now instructs to run shell command as root - Remove install file from source array since it's not needed there - Quote pkgdir - Cleanup/reformat install file language
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a18b8c4a5b2..8f5009222233 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=mastodon
-pkgver=2.4.2
-pkgrel=6
-pkgdesc='Your self-hosted, globally interconnected microblogging community'
+pkgver=2.4.3
+pkgrel=1
+pkgdesc='Free software social network server based on ActivityPub and OStatus'
arch=(i686 x86_64)
url=https://joinmastodon.org
-license=(AGPL-3.0)
+license=(AGPL3)
depends=(ffmpeg
imagemagick
libpqxx
@@ -18,21 +18,18 @@ depends=(ffmpeg
ruby-bundler
protobuf)
makedepends=(yarn python2)
-optdepends=('sudo: run commands as other users')
conflicts=(mastodon-git)
install=mastodon.install
-source=(https://github.com/tootsuite/mastodon/archive/v$pkgver.zip
+source=(https://github.com/tootsuite/mastodon/archive/v$pkgver.tar.gz
mastodon-web.service
mastodon-sidekiq.service
mastodon-streaming.service
- mastodon.target
- mastodon.install)
-sha512sums=(429f7f6513ae0a0bdb96c9fa5a30bb4cf446410227e092cef14fd29022865732cad65551bf789a28737236560c9228e9c2729a0210ea4af542eee6a710694c82
- 532929aeeda9a0ccf72de0695a3381547cc389344e1e67f05ef1d7ce5c1ad57278b647423bb52d4a87069ad85479452533fbe3786e5e5c4b62730c6ef72ff267
- 603a7877288c762855a29fd2399d3ff7d218a7f1b7d6378cad7f30048cdbfe2a13f2ed2b5c94cb683bdcaead8cd47243e564a2ae70d7f21fa33f295c5396f4f7
- 90a0761b7709659bec6f29c366c503fdd348226cbb585cf4f6eaa065854e2027d08ab3b352eb13ad7c0e327d662f13bc00fb4163ea0c583ef55b1795ab2e0b31
- c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb
- 1d301f6ae4725aea6d472f29e06c29caa84c688bde5d48f7ec0693e7b3d63662b04d5234d6ff01a2f93396b4c42a047d8c929886ff7eaa7d8b71768d13f4eb20)
+ mastodon.target)
+sha512sums=('0e84dffef9e10e302e381cc09eb37103e1c000cf4ffd056f5860f7c84a769b3a0d7ebf6cac40aa461d1eb10c74bf3c5cfaa111a51b038cecbf96b3737b5d5ff5'
+ '532929aeeda9a0ccf72de0695a3381547cc389344e1e67f05ef1d7ce5c1ad57278b647423bb52d4a87069ad85479452533fbe3786e5e5c4b62730c6ef72ff267'
+ '603a7877288c762855a29fd2399d3ff7d218a7f1b7d6378cad7f30048cdbfe2a13f2ed2b5c94cb683bdcaead8cd47243e564a2ae70d7f21fa33f295c5396f4f7'
+ '90a0761b7709659bec6f29c366c503fdd348226cbb585cf4f6eaa065854e2027d08ab3b352eb13ad7c0e327d662f13bc00fb4163ea0c583ef55b1795ab2e0b31'
+ 'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb')
build() {
cd mastodon-$pkgver
@@ -41,7 +38,7 @@ build() {
}
package() {
- install -d $pkgdir/{var/lib,usr/lib/systemd/system}
- cp -r $srcdir/mastodon-$pkgver $pkgdir/var/lib/mastodon
- cp $srcdir/mastodon-{web,sidekiq,streaming}.service mastodon.target $pkgdir/usr/lib/systemd/system
+ install -d "$pkgdir"/var/lib
+ cp -a mastodon-$pkgver "$pkgdir"/var/lib/mastodon
+ install -Dm 644 -t "$pkgdir"/usr/lib/systemd/system mastodon-{web,sidekiq,streaming}.service mastodon.target
}