summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2017-04-07 13:03:25 +0300
committerCaleb Maclennan2017-04-07 13:03:25 +0300
commit62ac5b177ff1c6b175544ca430e606ad6eefc979 (patch)
tree4f5aff3a7aa31e9745551d000cb172cf908a631d /PKGBUILD
downloadaur-62ac5b177ff1c6b175544ca430e606ad6eefc979.tar.gz
Initialize packgage meta data
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e76c72c042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=mastodon-docker-git
+pkgver=1.0_584_g1c351709
+_branch=master
+pkgrel=1
+pkgdesc="A GNU Social-compatible microblogging server"
+arch=('i686' 'x86_64')
+url="https://mastodon.social"
+license=('AGPL-3.0')
+conflicts=("${pkgname%-docker-git}", "${pkgname%-docker-git}-git", "${pkgname%-git}")
+source=("git://github.com/tootsuite/${pkgname%-git}.git#branch=$_branch")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/-/_/g'
+}
+