summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2017-04-21 16:53:47 +0300
committerCaleb Maclennan2017-04-21 16:53:47 +0300
commit5631570032b59addbe237f731743c906ef5574c5 (patch)
treec1378d660ae94c9839d8acdf1b4d08642396140b /PKGBUILD
parentaa5f944cec933dc979757659e30cbf7428a89b78 (diff)
downloadaur-5631570032b59addbe237f731743c906ef5574c5.tar.gz
Install systemd service and target files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fe948af33ad..951d347c90f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,6 +70,8 @@ post_install() {
echo ""
echo "4. Create an administrator account:"
echo " $ cd ~mastodon && sudo -u mastodon RAILS_ENV=production bundle exec rails mastodon:make_admin USERNAME=<username>"
+ echo ""
+ echo "5. Enable and start instance:"
}
post_upgrade() {
@@ -78,4 +80,8 @@ post_upgrade() {
package() {
cd "${pkgname%-git}"
+
+ for service in mastodon-{web,sidekiq,streaming}.service mastodon.target; do
+ install -Dm644 "${srcdir}/${service}" "${pkgdir}/usr/lib/systemd/system/${service}"
+ done
}