summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2017-04-07 12:47:46 +0300
committerCaleb Maclennan2017-04-07 12:47:46 +0300
commit75b295088c3c75c96ad424e040269185ddd5fc9d (patch)
tree379310766b1553bfe02180eb5d0069892c031101 /PKGBUILD
parent785f381ac31dcb15e8e33794c4cafc4aebe49304 (diff)
downloadaur-75b295088c3c75c96ad424e040269185ddd5fc9d.tar.gz
Add source location, package conflict info, and git version info
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c559968cd032..153ee04f8091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,19 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=mastodon-git
-pkgver=1.0
-pkgrel=0.1
+pkgver=1.0_584_g1c351709
+_branch=master
+pkgrel=1
pkgdesc="A GNU Social-compatible microblogging server"
arch=('i686' 'x86_64')
url="https://mastodon.social"
license=('AGPL-3.0')
+conflicts=("${pkgname%-git}")
+source=("git://github.com/tootsuite/${pkgname%-git}.git#branch=$_branch")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/-/_/g'
+}
+