summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Lisowski2020-04-21 16:48:48 +0200
committerMichał Lisowski2020-04-21 16:48:48 +0200
commit2f17915c56cf2cb09987127a1ff544aa964172f8 (patch)
tree250e77f8dd28f1791d3815d7e297c7eb9d013b65 /PKGBUILD
parent83b1a3c31101774500e4e9f3a582084743bc7239 (diff)
downloadaur-2f17915c56cf2cb09987127a1ff544aa964172f8.tar.gz
Add assets, deploy custom license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01e00da9b17c..2e5fcce1ab17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,22 @@
pkgname=maszyna-git
pkgver=r1277.c45081b2
-pkgrel=1
+pkgrel=2
pkgdesc="Polish train simulator"
arch=('x86_64')
url="https://eu07.pl/"
-license=('MPL2')
-makedepends=('cmake' 'git' 'glfw' 'glm' 'libserialport')
-source=("$pkgname"::'git://github.com/eu07/maszyna.git')
-md5sums=('SKIP')
+license=('MPL2' 'custom')
+makedepends=('cmake' 'git' 'glfw' 'glm' 'libserialport' 'p7zip')
+source=("$pkgname"::'git://github.com/eu07/maszyna.git'
+ "http://stuff.eu07.pl/MaSzyna1908.zip"
+ "http://stuff.eu07.pl/1908HF.zip"
+ "https://eu07.pl/theme/Maszyna/dokumentacja/inne/readme_pliki/licencja.html")
+noextract=('MaSzyna1908.zip'
+ '1908HF.zip')
+md5sums=('SKIP'
+ '1e33a4155c4dfeabfe8a72aaab6406be'
+ '70178c340fc236217343fe8ddcb63114'
+ 'fdbde83abd66899b540800c3d4b5f0a2')
pkgver() {
cd "$srcdir/$pkgname"
@@ -30,5 +38,8 @@ build() {
package() {
cd "$srcdir/$pkgname"
- install -D -m755 build/bin/eu07_$(date +'%y%m%d') "${pkgdir}/usr/bin/maszyna"
+ install -D -m755 build/bin/eu07_$(date +'%y%m%d') "${pkgdir}/opt/maszyna/eu07"
+ 7z x "${srcdir}/MaSzyna1908.zip" -o"${pkgdir}/opt/maszyna" -y
+ 7z x "${srcdir}/1908HF.zip" -o"${pkgdir}/opt/maszyna" -y
+ install -Dm644 licencja.html "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
}