summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJack Random2019-10-04 03:45:45 +0200
committerJack Random2019-10-04 03:45:45 +0200
commitfd1a53591e5e0457aaec29745198253814583685 (patch)
tree3dea82cd2e62e1852400d3802571b3e12117a13d /PKGBUILD
parentd9734a070d3ce6da154801e86c5bc28d72697069 (diff)
downloadaur-fd1a53591e5e0457aaec29745198253814583685.tar.gz
Major update
Use github source instead of sh**ty gnome-look website, install recommended way. Inspired by `matcha-gtk-theme-git` PKGBUILD, thanks to Kibouo!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2786971c591..4cd808d341c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,24 @@
# previous maintainer: grimi <grimi at poczta dot fm>
pkgname=matcha-gtk-theme
-pkgver=20190605
+pkgver=2019_10_03
pkgrel=1
pkgdesc="A flat design themes for GNOME, MATE, Openbox, Unity, XFCE, Budgie"
arch=('any')
-url='https://www.gnome-look.org/p/1187179'
+url='https://github.com/vinceliuice/matcha'
license=('GPL3')
depends=('gtk-engine-murrine' 'gtk-engines' 'gtk3')
-_hash_time=($(curl -s "$url"|grep -e "hash =" -e "timetamp ="|sed "s/.*= '\(.*\)';/\1/"))
-source=("https://dl.opendesktop.org/api/files/download/id/1559729670/s/${_hash_time[0]}/t/${_hash_time[1]}/lt/download/Matcha-sea.tar.xz"
- "https://dl.opendesktop.org/api/files/download/id/1559728977/s/${_hash_time[0]}/t/${_hash_time[1]}/lt/download/Matcha-azul.tar.xz"
- "https://dl.opendesktop.org/api/files/download/id/1559729711/s/${_hash_time[0]}/t/${_hash_time[1]}/lt/download/Matcha-aliz.tar.xz"
- )
+source=("https://github.com/vinceliuice/matcha/archive/${pkgver//_/-}.tar.gz")
-sha256sums=('4099b09e80c7df60de0a99862903c1082e1ae7cc726a89916316f8b5f55f6347'
- 'a2cd4048e495a1bf7d7277f2deedca1bb3fa7d33c7ca46ad282859399e30a070'
- '928e0e4b0caee0e9d158353fe962bdc89949e0a06b46f458aeec30c2d6a678e9'
- )
+sha256sums=('b32b3fbadcfdbee3ac6ed2c44c260da7dbf8f9ba8b9f42fa56f2e000a3a8542c')
package() {
- find Matcha{,-dark}-{sea,azul,aliz}/ -type f ! -name thumbnail.png -exec install -Dm644 "{}" "${pkgdir}/usr/share/themes/{}" \;
- find Matcha{,-dark}-{sea,azul,aliz}/ -type l -exec cp -d "{}" "${pkgdir}/usr/share/themes/{}" \;
+ mkdir "${pkgdir}"/usr
+ mkdir "${pkgdir}"/usr/share
+ mkdir "${pkgdir}"/usr/share/themes
+ cd "matcha-${pkgver//_/-}"
+ export _ORIGINAL_MATCHA_INSTALL_DIR=/usr/share/themes
+ export _NEW_MATCHA_INSTALL_DIR="${pkgdir}"/usr/share/themes
+ sed -i 's|'${_ORIGINAL_MATCHA_INSTALL_DIR}'|'${_NEW_MATCHA_INSTALL_DIR}'|g' ./Install
+ ./Install
}