summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeterCP2018-03-16 00:01:18 -0600
committerPeterCP2018-03-16 00:02:27 -0600
commit0258f7846f8c520a49badd9db4a4618517efc296 (patch)
treef55ad2337f101c60eafaf95c5a3a6d1f7776a8d3 /PKGBUILD
parentcaf21f8731bd926b3bf12a31dfecd35257017e6f (diff)
downloadaur-0258f7846f8c520a49badd9db4a4618517efc296.tar.gz
Update to 18.04.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 173feb7dc159..ad60980bd9cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
+# Maintainer: PeterCP <petercp@vivaldi.net>
# Maintainer: IKRadulov <ikradulov@vivaldi.net>
# Contributors:
-_ver=16.10
-_gitcom=d6f2a2fae6eb
-_pkgbase=mate-hud
-pkgname="${_pkgbase}"
-pkgver=${_ver}.0
+pkgname=mate-hud
+pkgver=18.04.7
pkgrel=1
-pkgdesc="Unity like HUD for Mate"
-url="https://bitbucket.org/ubuntu-mate/mate-hud.git"
-arch=('i686' 'x86_64')
-provides=("${_pkgbase}" "${_pkgbase}")
-conflicts=("${_pkgbase}" "${_pkgbase}")
-license=('GPL')
-depends=('appmenu-qt' 'libkeybinder3' 'mate-desktop' 'python' 'python-dbus' 'python-psutil' 'python-setproctitle' 'python-xlib' 'rofi' 'unity-gtk-module')
-source=("https://bitbucket.org/ubuntu-mate/mate-hud/get/16.10.0.tar.gz")
-sha1sums=('42e774916f021b411c8c39240118c8fb11f8b3a4')
-
-prepare() {
- msg "This will only work if you have UnityForArch repository"
-}
+pkgdesc="Run menubar commands, much like the unity 7 HUD"
+arch=('x86_64' 'i686')
+url="https://github.com/ubuntu-mate/mate-hud"
+license=('GPL2')
+depends=('rofi' 'gobject-introspection' 'mate-desktop' 'appmenu-gtk-module-git'
+ 'python' 'python-dbus' 'python-psutil' 'python-setproctitle'
+ 'python-xlib')
+optdepends=('appmenu-qt')
+makedepends=('python-setuptools')
+provides=('${pkgname}')
+conflicts=('${pkgname}')
+source=('https://github.com/ubuntu-mate/mate-hud/archive/18.04.7.tar.gz')
+sha256sums=('9c73b279033b43c03b3695ae617109fefe3fc8d8547f74a6da10df09b08f09c6')
package() {
- groups=('mate-extra')
- cd "${srcdir}/ubuntu-mate-mate-hud-${_gitcom}"
+ cd "${pkgname}-${pkgver}"
./setup.py "install" "--root=${pkgdir}" "--optimize=1"
}