summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorreztho2015-06-13 23:22:26 +0100
committerreztho2015-06-13 23:22:26 +0100
commitfca21e48ee6b32e0386a379ed237799b028e1199 (patch)
tree194361800379c4f6f4c07a580b908cb0eb4aed13 /PKGBUILD
downloadaur-fca21e48ee6b32e0386a379ed237799b028e1199.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6161d26d35f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tom < reztho at archlinux dot us >
+pkgname=mate-tweak-git
+pkgver=3.4.7.r0.2d912fa
+pkgrel=1
+pkgdesc="Mate desktop configuration tool"
+arch=('any')
+url="https://bitbucket.org/ubuntu-mate/mate-tweak"
+license=('GPL')
+depends=('python2' 'wmctrl')
+makedepends=('git' 'python2-setuptools' 'python2-distutils-extra')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('mate-tweak::git+https://bitbucket.org/ubuntu-mate/mate-tweak.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ /usr/bin/python2 setup.py install --root="$pkgdir/" --optimize=1
+}