summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOleg Shparber2020-09-07 19:41:37 -0400
committerOleg Shparber2020-09-07 19:47:31 -0400
commit321158e0fa309e0a95262cb2239f613ef607d0fb (patch)
tree42ef51311291de073db8c78ce676fa0917b55363 /PKGBUILD
downloadaur-321158e0fa309e0a95262cb2239f613ef607d0fb.tar.gz
add otf-material-icons-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..241d3890a0f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Oleg Shparber <trollixx+aur@gmail.com>
+
+_gitname=material-design-icons
+pkgbase=material-icons-git
+#pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
+pkgname=("otf-${pkgbase}")
+pkgver=4.0.0.r3.g96206ade0e
+pkgrel=1
+pkgdesc="Material design icons is the official icon set from Google."
+url='https://github.com/google/material-design-icons'
+arch=('any')
+license=('Apache')
+makedepends=('git')
+#provides=("otf-material-icons=${pkgver}" "ttf-material-icons=${pkgver}")
+provides=("otf-material-icons=${pkgver}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_otf-material-icons-git() {
+ cd "${_gitname}"
+ install -Dm644 font/*.otf -t "$pkgdir"/usr/share/fonts/OTF
+}
+
+# package_ttf-material-icons-git() {
+# cd "${_gitname}"
+# install -Dm644 font/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
+# }