summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMort Yao2017-10-19 17:27:54 +0200
committerMort Yao2017-10-19 17:27:54 +0200
commitd4149db1ce90732332f42af969a6c15daea6fe0c (patch)
treea61448425ac088722ef5ce0dd3a1ff4f5cbec009 /PKGBUILD
downloadaur-d4149db1ce90732332f42af969a6c15daea6fe0c.tar.gz
mathcomp-git 20170913-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b19fb1ec11bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=mathcomp-git
+pkgver=20170913
+pkgrel=1
+pkgdesc="The Mathematical Components Library for the Coq system."
+url="https://math-comp.github.io/math-comp/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('coq>=8.5')
+makedepends=('camlp5>=7.02' 'ocaml-findlib')
+provides=('mathcomp')
+conflicts=('mathcomp')
+source=("${pkgname}::git://github.com/math-comp/math-comp.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$srcdir/$pkgname/mathcomp"
+
+ make -j 3
+}
+
+package() {
+ cd "$srcdir/$pkgname/mathcomp"
+
+ make DSTROOT="$pkgdir/usr/lib/coq/" install
+}