summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndres Urquijo2017-06-17 00:26:21 -0500
committerAndres Urquijo2017-06-17 00:26:21 -0500
commitadcb7107afaa6e07f4488a85f524c62297035dc1 (patch)
treecfafc5af2875dc9e75813f99a7995349ebf79630 /PKGBUILD
parent2624443c01e0501bca2ccfec1efe6eee9b41e1a7 (diff)
downloadaur-adcb7107afaa6e07f4488a85f524c62297035dc1.tar.gz
New version 2.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4b3b76885dd..e81aa474c316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Andres Urquijo <alfagalileox@gmail.com>
pkgname=mathgl
-pkgver=2.3.5
+pkgver=2.4
pkgrel=1
pkgdesc="A library for making high-quality scientific graphics"
arch=('i686' 'x86_64')
@@ -11,20 +11,19 @@ depends=('libpng' 'libharu' 'python2' 'hdf5' 'texlive-bin' 'texlive-core' 'pytho
'freeglut' 'gsl' 'wxgtk' 'qt5-base' )
makedepends=( 'cmake' 'swig')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}%20${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('7eb03b533e877be22d24f46800b712b4')
+md5sums=('5b23345d322df18a326f1ce40b38ab37')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
[[ -d build ]] || mkdir build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -Denable-all-widgets=OFF \
-Denable-double=ON \
- -Denable-json=ON \
- -Denable-json-sample=ON \
-Denable-mgltex=ON \
-Denable-opengl=ON \
- -Denable-doc-pdf-en=OFF \
- -Denable-all-docs=OFF \
+ -Denable-doc-pdf-en=ON \
+ -Denable-all-docs=ON \
-Denable-gif=ON \
-Denable-glut=ON \
-Denable-hdf5=ON \
@@ -33,9 +32,6 @@ build() {
-Denable-gsl=ON \
-Denable-pdf=ON \
-Denable-png=ON \
- -Denable-python=ON \
- -Denable-octave=ON \
- -Denable-wx=ON \
-Denable-qt5=ON
make
}