summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor2021-07-08 09:31:26 +0200
committerVictor2021-07-08 09:31:26 +0200
commit14f78bceb0d9d80a55501ab2c4a47a3f448abc3b (patch)
treecc46cbab1d4c2f7fc094dcb8bfe5aa8573f805b3 /PKGBUILD
parentf81b58f757511ad436d2729de5730b87760f7a59 (diff)
downloadaur-14f78bceb0d9d80a55501ab2c4a47a3f448abc3b.tar.gz
Update to 3.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b158a1df436..5382ea192ad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,22 @@
pkgname=mathics
_pkgname=Mathics3
-pkgver=2.2.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="A general-purpose computer algebra system."
arch=('any')
url="https://mathics.org/"
license=('GPL3')
depends=('mathics-scanner' 'python-sympy' 'python-mpmath' 'python-numpy'
- 'python-palettable' 'python-pint' 'python-dateutil' 'python-psutil'
- 'python-llvmlite' 'python-requests' 'cython' 'python-scikit-image'
- 'python-wordcloud' 'python-lxml')
+ 'python-palettable' 'python-pint' 'python-dateutil' 'python-llvmlite'
+ 'python-requests' 'cython')
makedepends=('python-setuptools')
+optdepends=( 'python-psutil: SystemMemory and MemoryAvailable'
+ 'python-scikit-image: FindMinimum can use this'
+ 'python-lxml: for HTML parsing used in builtin/fileformats/html'
+ 'python-wordcloud: Used in builtin/image.py by WordCloud')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mathics/Mathics/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz")
-sha256sums=('5d84244bbfbcc4c6cc3ac2678ef1af8f3f51167d2bf050f67c8b2475ac4c6ee4')
+sha256sums=('dd01edc2eb5d6718db0cc35d428907277289501a37688ab60a645036723e6309')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"