summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2021-04-19 09:31:43 +0200
committerMark Collins2021-04-19 09:33:17 +0200
commitb524d72bd0fec1aa6aacb73203ea0f8c8e4b65d7 (patch)
treefc2041972cfd63864beacd9ad34d1592ee255659 /PKGBUILD
downloadaur-b524d72bd0fec1aa6aacb73203ea0f8c8e4b65d7.tar.gz
Initial commit: Simple CLI-based Matrix client for sending and receiving PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4299a0b539b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mark Collins <tera_1225 hat hotmail.com>
+pkgname=matrix-commander-git
+pkgver=r64.3e89a5f
+pkgrel=1
+pkgdesc="Simple but convenient CLI-based Matrix client app for sending and receiving"
+arch=('any')
+url="https://github.com/8go/matrix-commander"
+license=('GPL')
+depends=( "python-aiohttp"
+ "python-aiofiles"
+ "python-argparse"
+ "python-markdown"
+ "python-matrix-nio"
+ "python-notify2"
+ "python-pillow"
+ "python-magic-git")
+provides=("matrix-commander")
+conflicts=("matrix-commander")
+source=("${pkgname%-git}::git+https://github.com/8go/matrix-commander.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ local _site_packages
+ _site_packages="$(python -c "import site; print(site.getsitepackages()[0])")"
+ install -d "${pkgdir}${_site_packages}/${pkgname%-git}/bin/"
+ cd "${pkgname%-git}" || exit 1
+ install -D -m 755 "./matrix-commander.py" "${pkgdir}/${_site_packages}/${pkgname%-git}/bin/"
+ install -d "$pkgdir/usr/bin/"
+ cd "$pkgdir/usr/bin/" || exit 1
+ ln -s "${_site_packages}/${pkgname%-git}/bin/matrix-commander.py" "matrix-commander"
+}