summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShizcow2020-04-07 20:43:38 -0600
committerShizcow2020-04-07 20:43:38 -0600
commit8bc1a28b2c39d781ff04a46e279aa085b2932102 (patch)
treea5c48eede47bfb91306e33a7ec103d255e74f2f1 /PKGBUILD
downloadaur-8bc1a28b2c39d781ff04a46e279aa085b2932102.tar.gz
It works usually
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7785fa3f926
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+
+pkgname=matrixise
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Turn anything into 'The Matrix' wallpaper"
+arch=('any')
+url="https://github.com/Shizcow/matrixise"
+license=('GPL2')
+depends=('ncurses')
+makedepends=('rust' 'git')
+source=(
+ "${pkgname}::git+${url}.git"
+)
+md5sums=('SKIP')
+build() (
+ cd matrixise
+ cargo build --release --examples
+)
+package() (
+ install -D -m 755 ${srcdir}/matrixise/target/release/examples/stdin ${pkgdir}/usr/bin/$pkgname
+) \ No newline at end of file