summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex J. Malozemoff2018-11-26 16:44:58 -0800
committerAlex J. Malozemoff2018-11-26 16:44:58 -0800
commit689939642366340ffd818ceb4bc9c39e326cf1ef (patch)
treec324ee0b8f3d13018ea20af9153cdda3c2ce3f63 /PKGBUILD
parentca3618d2f01b5ddca28d018d5460b55b7b5df99a (diff)
downloadaur-689939642366340ffd818ceb4bc9c39e326cf1ef.tar.gz
matterhorn v50200.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18f1bd8a2d80..da6d208ca6ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn
-pkgver=40901.0.0
-pkgrel=3
+pkgver=50200.0.0
+pkgrel=1
pkgdesc="A terminal-based chat client for MatterMost"
arch=('any')
url="https://github.com/matterhorn-chat/matterhorn"
@@ -9,13 +9,15 @@ license=('BSD')
provides=('matterhorn')
conflicts=('matterhorn-git' 'matterhorn-bin')
depends=('ncurses5-compat-libs')
-makedepends=('git' 'cabal-static' 'ghc-static')
+makedepends=('git' 'cabal-install' 'ghc8.2')
source=("https://github.com/matterhorn-chat/matterhorn/archive/${pkgver}.tar.gz")
-sha1sums=('183fc10600066a1ad47d235fc29597300eb14ca3')
+sha1sums=('85ffbff17f4e73b54302df74e69aa4a29083f3d9')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./install.sh
+ rm -f cabal.project
+ cabal new-update
+ cabal new-build -j -w /usr/bin/ghc-8.2
}
package() {