summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex J. Malozemoff2019-12-02 10:57:40 -0800
committerAlex J. Malozemoff2019-12-02 10:57:40 -0800
commit81bf9b0a9d9ef33e923b9c67960b047f98df0f2d (patch)
tree8a62625592f6f4ec7d04d7192a012ac0de3eb1bd /PKGBUILD
parent3d2e1cb56f8b2eab935136c301e7a424839109bb (diff)
downloadaur-81bf9b0a9d9ef33e923b9c67960b047f98df0f2d.tar.gz
integrate in ekkelett's changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fe5cbc01b9d..e116eef916c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Contributor: Thor K. Høgås <thor at roht.no>
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn
pkgver=50200.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A terminal-based chat client for MatterMost"
arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
@@ -9,7 +10,7 @@ license=('BSD')
provides=('matterhorn')
conflicts=('matterhorn-git' 'matterhorn-bin')
depends=('gmp' 'zlib')
-makedepends=('cabal-install' 'ghc8.2')
+makedepends=('cabal-install' 'ghc')
source=("https://github.com/matterhorn-chat/matterhorn/archive/${pkgver}.tar.gz")
sha1sums=('e63297435cedd9ce2cf7631ada3609f9b63deb7e')
@@ -17,7 +18,7 @@ build() {
cd "${srcdir}/${pkgname}-${pkgver}"
rm -f cabal.project
cabal new-update
- cabal new-build -j -w /usr/bin/ghc-8.2
+ cabal new-build -j --enable-shared --enable-executable-dynamic --ghc-options=-dynamic
}
package() {