summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex J. Malozemoff2020-10-22 08:30:54 -0700
committerAlex J. Malozemoff2020-10-22 08:30:54 -0700
commit5b27be1cd18bae254a2ea3bfc9a0be88027a5b84 (patch)
treed7a2a721555746e439ba3022b896cbcddca26e83 /PKGBUILD
parent9b5e0866b9ac0c95118e6daed1dbbf2c6c62de27 (diff)
downloadaur-matterhorn-git.tar.gz
clean up PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8bf38cf6359..17a14aa54675 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn-git
_pkgname=matterhorn
-pkgver=50200.1.0
+pkgver=50200.11.0
pkgver() {
cd ${_pkgname}
git describe --long --tags | cut -d- -f1
@@ -12,17 +12,17 @@ arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
depends=('gmp' 'zlib')
-makedepends=('git' 'cabal-install' 'ghc8.2')
+makedepends=('git' 'cabal-install' 'ghc')
source=("git+https://github.com/matterhorn-chat/matterhorn.git")
sha1sums=('SKIP')
-provides=('matterhorn-git')
-conflicts=('matterhorn' 'matterhorn-bin')
+provides=('matterhorn')
+conflicts=('matterhorn')
build() {
cd ${srcdir}/${_pkgname}
git submodule update --init
cabal new-update
- cabal new-build -w /usr/bin/ghc-8.2
+ cabal new-build
}
package() {