summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoakim Repomaa2019-10-31 15:23:37 +0100
committerJoakim Repomaa2019-10-31 15:23:37 +0100
commitde3b50d477d740c1114c8f26a86bbbc8243fdfe5 (patch)
tree18148c0eb41b9cb980ccd67bd0289fe64c50cc31 /PKGBUILD
parentd5417e0e0e6756c16721f935257e8b1164ca0e32 (diff)
downloadaur-de3b50d477d740c1114c8f26a86bbbc8243fdfe5.tar.gz
get dependencies during prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d070891db38..884abd126d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname='matterircd'
_github_path="github.com/42wim/${pkgname}"
_go_pkg_path="src/${_github_path}"
pkgver='0.19.2'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Minimal IRC server which integrates with mattermost and slack'
arch=('x86_64')
url='https://github.com/42wim/matterircd'
@@ -32,6 +32,8 @@ prepare() {
export PATH="$PATH:$GOPATH/bin"
mkdir -p "$(dirname "${_go_pkg_path}")"
mv "${pkgname}-${pkgver}" "${_go_pkg_path}"
+ cd "${_go_pkg_path}"
+ go get ./...
}
build() {