summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-05-20 19:02:24 +0200
committerAleksandar Trifunovic2018-05-20 19:02:24 +0200
commitf1dc9e998c291b9b92b13d11d75d3a3679b6b325 (patch)
tree6ecb8a1ba80bbf432c6e29de2720ad1979b99ea4 /PKGBUILD
parent54c9004ddc8df22803437cdd67cdde1945fc3f65 (diff)
downloadaur-f1dc9e998c291b9b92b13d11d75d3a3679b6b325.tar.gz
simlify sed commands and push v4.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21847383d5c0..d2831953693b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,25 +23,22 @@ prepare() {
# Depending on the architecture, in order to accelerate the build process,
# removes the compilation of ia32 or x64 build.
- case "$CARCH" in
- i686)
- sed -i 's/build --linux --x64 --ia32/build --linux --ia32/g' package.json
- ;;
- x86_64)
- sed -i 's/build --linux --x64 --ia32/build --linux --x64/g' package.json
- ;;
- esac
+ if [[ "$CARCH" == x86_64 ]];then
+ sed -i 's/--ia32//g' package.json
+ else
+ sed -i 's/--x64//g' package.json
+ fi
# Reduce build time by removing the creation of a .deb for Debian
- sed -i -e '/^[[:space:]]*"target": \[/!b' -e '$!N;s/\n[[:space:]]*"deb",//' electron-builder.json
- # No need to compress package
+ sed -i -e '/"deb",/d' electron-builder.json
+ # No need to compress the package
sed -i 's/tar.gz/dir/' electron-builder.json
}
build() {
cd "${srcdir}/desktop-${pkgver}"
- # Hack for bug https://github.com/npm/npm/issues/19989
+ # Hack (npm bug? https://github.com/npm/npm/issues/19989)
{
npm install --cache "${srcdir}/npm-cache"
} || {