summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralmir2021-06-24 12:19:27 +0200
committeralmir2021-06-24 12:19:27 +0200
commit94f6202a5d3515d59c09f97c25cf1cbfcdce1c07 (patch)
tree20e27bbe5345bfc57cf26f92935d216d066d9264 /PKGBUILD
parente26815e47147b792e43ea4ad41a5d38fadfad4d4 (diff)
downloadaur-94f6202a5d3515d59c09f97c25cf1cbfcdce1c07.tar.gz
- fix copying the icon svg file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 082170fa145f..bba6fcff635c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('i686' 'x86_64')
url="https://github.com/mattermost/desktop"
license=('Apache')
-makedepends=()
+makedepends=('npm')
depends=('alsa-lib' 'gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'libutil-linux' 'libappindicator-gtk3' 'libsecret')
optdepends=()
@@ -39,6 +39,9 @@ package() {
cp -r * "$pkgdir/usr/lib/mattermost"
+ cd "$pkgdir/usr/lib/mattermost"
+ npx asar extract-file "$pkgdir/usr/lib/mattermost/resources/app.asar" assets/linux/icon.svg
+
install -d -m 755 "$pkgdir/usr/bin"
ln -s /usr/lib/mattermost/${_pkgname} "$pkgdir/usr/bin/$_pkgname"