summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWachid Adi Nugroho2024-04-30 15:43:17 +0700
committerWachid Adi Nugroho2024-04-30 15:43:17 +0700
commit9371d6ae3746008046b11f1024225469463069f0 (patch)
treea08bf876911d33646406c06479b1ca4bb8f3fffa /PKGBUILD
parent9028533b0dc91c534cfb1bd5f1b1a060eb44e9f9 (diff)
downloadaur-9371d6ae3746008046b11f1024225469463069f0.tar.gz
Bump version to 4.0.0.r32.gee207a0-1: Update depends list, use qt6 branch and build with Qt6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b431a836d7b..3d9999b6c636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=mauikit-documents
pkgname=$_pkgname-git
-pkgver=1.1.0.r1.gad9185a
+pkgver=4.0.0.r32.gee207a0
pkgrel=1
pkgdesc='MauiKit Documents components'
url='https://invent.kde.org/maui/mauikit-documents'
@@ -17,18 +17,25 @@ depends=(karchive
kio
ki18n
mauikit-git
- poppler-qt5
- qt5-base
- qt5-declarative
- qt5-quickcontrols2
+ poppler-qt6
+ qt6-base
+ qt6-declarative
+ qt6-quickcontrols2
zlib)
makedepends=(git extra-cmake-modules)
groups=(maui)
provides=($_pkgname)
conflicts=($_pkgname)
-source=(git+$url.git)
+source=(git+$url.git#branch=qt6)
sha256sums=('SKIP')
+prepare() {
+ cd $_pkgname
+ git tag -d $(git tag -l) > /dev/null
+ git tag -a v4.0.0 00d8ad64 -m v4.0.0
+ git checkout -b aur
+}
+
pkgver() {
cd $_pkgname
( set -o pipefail
@@ -41,6 +48,7 @@ build() {
cmake -B build -S $_pkgname \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_WITH_QT6=ON -Wno-dev \
-DCMAKE_INSTALL_LIBDIR=/usr/lib
cmake --build build
}