summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-10-29 14:28:57 +0100
committerFabioLolix2023-10-29 14:28:57 +0100
commitf111b3d4cbdd83b62dcfd798246d99753e54fec8 (patch)
tree2485a2e228e561947854c0c9ba82fbbfd50aff76 /PKGBUILD
parentb686375734588009eabfbeab89b253df3bf1791c (diff)
downloadaur-f111b3d4cbdd83b62dcfd798246d99753e54fec8.tar.gz
depends revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 402676179a21..9f1f30c0ceb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,33 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
-
+
pkgname=mauikit-git
-pkgver=2.2.1.r142.g0cc9ede3
-pkgrel=1
+pkgver=3.0.1.r64.g277a2870
+pkgrel=2
pkgdesc='Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG'
-arch=(x86_64 i686 arm armv6h armv7h aarch64)
+arch=(x86_64 i686 armv7h aarch64)
url="https://mauikit.org/"
-license=(GPL3)
+license=(LGPL3)
groups=(maui)
-depends=(qt5-base qt5-declarative qt5-quickcontrols2 knotifications ki18n mauiman)
-makedepends=(git cmake extra-cmake-modules qt5-webengine appstream syntax-highlighting plasma-framework)
+depends=(qt5-base qt5-declarative qt5-quickcontrols2 knotifications5 ki18n5 mauiman-git)
+makedepends=(git cmake extra-cmake-modules qt5-webengine appstream syntax-highlighting5 plasma-framework5)
provides=(mauikit)
conflicts=(mauikit)
source=("git+https://invent.kde.org/kde/mauikit.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
+ cd "mauikit"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-git}"
- cmake . \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
+ cmake -B build -S "mauikit" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ cmake --build build
}
-
+
package() {
- cd "${pkgname%-git}"
- make DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" cmake --install build
}