summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Pujol2019-09-07 14:33:37 +0100
committerAlexandre Pujol2019-09-07 14:33:37 +0100
commit488e5e85fb593e06e25564a77e2ead54595993f1 (patch)
tree972a6fd9a49552d7fc6d74269dff74351249b633 /PKGBUILD
parent2fe617c6e304d9180294a459c24abc87ae9f87d4 (diff)
downloadaur-488e5e85fb593e06e25564a77e2ead54595993f1.tar.gz
upgpkg: mausoleum 0.8.3-3
Rewrite the pkgbuild.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dafafa329558..8c6433edbec5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,49 @@
# Maintainer: Alexandre Pujol <alexandre@pujol.io>
_name='mausoleum'
-pkgname="${_name}"
+pkgname="$_name"
pkgver=0.8.3
-pkgrel=2
+pkgrel=3
pkgdesc='A Python GUI application, command line interface, and wrapper for Tomb'
arch=('any')
url='https://github.com/mandeep/Mausoleum'
license=('GPL3')
makedepends=('python-setuptools')
-depends=('tomb'
- 'python-pyqt5'
- 'python-pytoml'
- 'python-click'
- 'python-appdirs')
-conflicts=("${_name}-git")
-provides=("${_name}" "${_name}-gui")
-source=("https://github.com/mandeep/Mausoleum/archive/v${pkgver}.tar.gz"
+depends=(
+ 'tomb'
+ 'python-pyqt5'
+ 'python-pytoml'
+ 'python-click'
+ 'python-appdirs'
+)
+conflicts=("$_name-git")
+provides=("$_name" "$_name-gui")
+source=("https://github.com/mandeep/Mausoleum/archive/v$pkgver.tar.gz"
"mausoleum.desktop")
sha512sums=('23ec29c2393125558da0db9f04bbdf995a46d8166dee8ba6dbe4d66bb669f48c6ce8f40c41db2073897deb5f329fe8c203ac3ba42da8d2aefddb3d5068d53106'
- '1f0ca9c2b377be3c2d55d291013a8cab79499bd038216f18429f07918c6815c94474a19e4668c9e7bd8db6eb9358ef1dd9b8d91fb39bdb83c6a62114c5cdafe1')
+ 'fdb2db16c6e8fa3f86a51198d732e50387ea174384ed5f23d7db35f62c00137c84add144fb2e0305d1ea52ee233f8f9f779ef49778ac97f26410ae1a2a2d8ed3')
prepare() {
# Use latest archlinux dependencies
- cd "${srcdir}/Mausoleum-${pkgver}"
+ cd "Mausoleum-$pkgver"
sed -i -e "s/==[0-9.]*//g" setup.py
}
+build() {
+ cd "Mausoleum-$pkgver"
+ python setup.py build
+}
+
package() {
- cd "${srcdir}/Mausoleum-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "Mausoleum-$pkgver"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # Care for the icon
+ install -Dm644 mausoleum/images/ic_vpn_key_black_48dp_1x.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/$_name.png"
- # Desktop file
- install -Dm644 "${srcdir}/${_name}.desktop" "${pkgdir}/usr/share/applications/${_name}.desktop"
+ # Compose the desktop entry
+ export name="$_name" pkgver pkgdesc
+ install -d "$pkgdir"/usr/share/applications
+ envsubst < "$srcdir/$_name.desktop" > "$pkgdir/usr/share/applications/$_name.desktop"
}