summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainDamage2021-03-15 08:45:04 +0100
committerBrainDamage2021-03-15 08:45:04 +0100
commit4d8128f58cd17ff9a40b0c613a7076bf58039e87 (patch)
tree41601cceb8030d87f72a3942d7f335123c52f026 /PKGBUILD
parentab2dd4c83b7450fd1b6a37d1699a5076270d353b (diff)
downloadaur-4d8128f58cd17ff9a40b0c613a7076bf58039e87.tar.gz
added python-pytest-runner to makedeps, setuptools changed behaviour wrt missing optional deps and it'd attempt to install it using pip and fail
use python-magic-ahupp by name, this will prevent python-magic from the official repos to be picked
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f128d3eba369..8ca1ccaba259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: BrainDamage
pkgname=mautrix-telegram
pkgver=0.9.0
-pkgrel=5
+pkgrel=6
pkgdesc="A Matrix-Telegram hybrid puppeting/relaybot bridge."
url="https://github.com/tulir/mautrix-telegram"
depends=('python' 'python-sqlalchemy' 'python-alembic' 'python-ruamel-yaml'
- 'python-magic<0.5' 'python-commonmark' 'python-aiohttp' 'python-yarl'
+ 'python-magic-ahupp' 'python-commonmark' 'python-aiohttp' 'python-yarl'
'python-mautrix' 'python-telethon<1.18' 'python-telethon-session-sqlalchemy')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-pytest-runner')
optdepends=('python-cryptg: faster encryption'
'python-cchardet: faster encoding detection'
'python-brotlipy: faster compression'