summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainDamage2020-11-17 20:06:54 +0100
committerBrainDamage2020-11-17 20:06:54 +0100
commitd3cfe03602e0baa7bbae27d26cc300f0e1320c72 (patch)
treeaf2188763a2f9c7595c30cad7c039fb6cf4089b0 /PKGBUILD
parentd947709fedd6b057d973a028063cebc82072988d (diff)
downloadaur-d3cfe03602e0baa7bbae27d26cc300f0e1320c72.tar.gz
updated to version 9.0
updated service file to not use the launcher bin updateed optional deps updated mautrix lib boundaries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f528834ec69d..2950c7d28697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
# Maintainer: BrainDamage
pkgname=mautrix-telegram
-pkgver=0.8.2
-pkgrel=7
+pkgver=0.9.0
+pkgrel=1
pkgdesc="A Matrix-Telegram hybrid puppeting/relaybot bridge."
url="https://github.com/tulir/mautrix-telegram"
depends=('python' 'python-sqlalchemy' 'python-alembic' 'python-ruamel-yaml'
'python-magic' 'python-commonmark' 'python-aiohttp' 'python-yarl'
- 'python-mautrix<0.6' 'python-telethon' 'python-telethon-session-sqlalchemy')
+ 'python-mautrix>=0.8.3' 'python-telethon' 'python-telethon-session-sqlalchemy')
makedepends=('python-setuptools')
optdepends=('python-cryptg: faster encryption'
'python-cchardet: faster encoding detection'
+ 'python-brotlipy: faster compression'
'python-aiodns: asyncronous dns requests'
'python-pillow: webp conversion and qr code login'
'python-qrcode: qr code login'
'python-moviepy: high quality thumbnails'
'python-prometheus_client: metrics upload'
'python-psycopg2: postgresql database support'
- 'python-matrix-nio: end-to-bridge encryption support')
+ 'python-asyncpg: end-to-bridge encryption support'
+ 'python-olm: end-to-bridge encryption support'
+ 'python-pycryptodome: end-to-bridge encryption support'
+ 'python-unpaddedbase64: end-to-bridge encryption support')
license=('AGPLv3')
arch=('any')
source=("${url}/archive/v${pkgver}.tar.gz" "${pkgname}.service" "${pkgname}.sysusers" "${pkgname}.tmpfiles")
-sha256sums=('1f227f50e84f643fc7633f1a8f336aa1e51db6c12628e983783c2995a41d497f'
- '7d947a08bff4bf172346682d68af6071e5df556d16065b439aa312edc57e5e84'
- 'fce0a4f792e62d9440fe431fb6ab6c458139bcc801bc2b02bc1b3d8f2ff9fcbf'
- 'e6d4565350477d180c639cc1e0805d475ef036e870db671b22374e9c91f95c7c')
+sha256sums=('e0fb30bf448f1bec6f27f73662c1dcddd36986367dcbe4f34509b23af67142a9'
+ '60fc960c50422245b081c9e6300f3a2728c4820e004f46b1f046634ec8670ab0'
+ 'fce0a4f792e62d9440fe431fb6ab6c458139bcc801bc2b02bc1b3d8f2ff9fcbf'
+ 'e6d4565350477d180c639cc1e0805d475ef036e870db671b22374e9c91f95c7c')
backup=("etc/${pkgname}/config.yaml" "etc/${pkgname}/registration.yaml")
install="${pkgname}.install"
@@ -47,16 +51,15 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
_shared_dir="/usr/share/${pkgname}"
+
python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr" --install-data="${_shared_dir}"
# it's a semi-common failure for python packages to install tests in the main dir
# which would make them conflict eachother
rm -rf "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/tests"
- # TODO: remove this when ver 9 gets out of rc since it installs the example config to the data dir properly
- mv "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/${pkgname//-/_}/example-config.yaml" "${pkgdir}${_shared_dir}"
-
# adjust alembic script dir location so that by using an abs path it can be used in CWD
sed -i -e "s|script_location = alembic|script_location = ${_shared_dir}/alembic/|" "${pkgdir}${_shared_dir}/alembic.ini"