summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralive4ever2016-08-21 17:09:04 +0700
committeralive4ever2016-08-21 17:09:04 +0700
commit4f5d0ccb78ab6a9aa53039d7381d18269fbdecfc (patch)
tree130b58bc9384314fc5db655fcfc5f3997a092265 /PKGBUILD
downloadaur-4f5d0ccb78ab6a9aa53039d7381d18269fbdecfc.tar.gz
Initial commit
Maynard is a new project to provide lightweight desktop shell based on weston compositor for use with wayland display protocol. It's built for Raspberry Pi, but it's portable so you can compile it anywhere. Expect many bugs and crashes, so beware when you are using this desktop shell to work with important files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43c63d634cb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: alive4ever <alive4ever at live.com>
+pkgname=maynard-git
+pkgver=r121.a191e5c
+pkgrel=1
+pkgdesc="Lightweight desktop environment based on Weston compositor for use with Wayland"
+arch=('x86_64' 'i686')
+url="https://github.com/raspberrypi/maynard"
+license=('custom:MIT' 'GPL')
+provides=("maynard")
+depends=("weston")
+makedepends=('git')
+install=maynard.install
+source=("${pkgname%-VCS}::git+https://github.com/raspberrypi/maynard.git")
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+ #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/${pkgname%-VCS}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libexecdir=/usr/lib/maynard --sysconfdir=/etc --bindir=/usr/bin --libdir=/usr/lib
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-VCS}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-VCS}"
+ make DESTDIR="$pkgdir/" install
+}