summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralive4ever2016-08-22 10:38:42 +0700
committeralive4ever2016-08-22 10:38:42 +0700
commite6479a8262e94d2200696bddfe4befec54befa0d (patch)
tree3582fc8ab51b6d5df935e4c2cc16049d64832105 /PKGBUILD
parent4f5d0ccb78ab6a9aa53039d7381d18269fbdecfc (diff)
downloadaur-e6479a8262e94d2200696bddfe4befec54befa0d.tar.gz
Fix dependency issue on clean chroot
Since the first commit was done on my host system which has many packages installed, I didn't include anything except weston as runtime dependency. I've patched maynard script to reflect better compile time definition. I've also set default wallpaper to weston background instead of missing file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43c63d634cb5..5fd0e5ff3529 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,45 +7,39 @@ arch=('x86_64' 'i686')
url="https://github.com/raspberrypi/maynard"
license=('custom:MIT' 'GPL')
provides=("maynard")
-depends=("weston")
-makedepends=('git')
+depends=("weston" "gnome-desktop")
+makedepends=("git" "intltool")
install=maynard.install
-source=("${pkgname%-VCS}::git+https://github.com/raspberrypi/maynard.git")
-sha256sums=('SKIP')
-
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
+source=("${pkgname%-git}::git+https://github.com/raspberrypi/maynard.git"
+ "01-maynard.patch")
+sha256sums=('SKIP'
+ '07fb68ed8dcebca0ec9272ac0707b622a5c599e12ab0360947d031a572fff35c')
pkgver() {
- cd "$srcdir/${pkgname%-VCS}"
-
-# The examples below are not absolute and need to be adapted to each repo. The
-# primary goal is to generate version numbers that will increase according to
-# pacman's version comparisons with later commits to the repo. The format
-# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
-# are not available, is recommended.
-
-# Git, tags available
- #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
-# Git, no tags available
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 < "$srcdir/01-maynard.patch"
+}
+
build() {
- cd "$srcdir/${pkgname%-VCS}"
+ cd "$srcdir/${pkgname%-git}"
./autogen.sh
./configure --prefix=/usr --libexecdir=/usr/lib/maynard --sysconfdir=/etc --bindir=/usr/bin --libdir=/usr/lib
make
}
check() {
- cd "$srcdir/${pkgname%-VCS}"
+ cd "$srcdir/${pkgname%-git}"
make -k check
}
package() {
- cd "$srcdir/${pkgname%-VCS}"
+ cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir/" install
}