summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Zanoni2024-03-04 22:12:31 +0100
committerAndrea Zanoni2024-03-04 22:12:31 +0100
commit890bc839adcadf09d17bc041622e7fa0220b2f26 (patch)
tree84eb89f5b26a9e06b4fbe0749418709a849eabb4 /PKGBUILD
parentc4bc586f6845663b98e05e0f8241295260abd450 (diff)
parentbbd66489c28e1cf8999e0e9ad952d3e90ea6e621 (diff)
downloadaur-890bc839adcadf09d17bc041622e7fa0220b2f26.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/mbdyn-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0f80bdd73fb..36ab3a2454a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,13 @@ pkgdesc="The first *free* general purpose Multibody Dynamics analysis software"
arch=('any')
url='www.mbdyn.org'
license=('GPLv2')
-depends=(openblas-lapack suitesparse netcdf netcdf-cxx)
+depends=(suitesparse netcdf netcdf-cxx)
makedepends=(git autoconf automake gcc-fortran libtool)
-optdepends=('ginac: symbolic elements support')
+optdepends=('ginac: symbolic elements support',
+ 'lapack: eigenanalysis support',
+ 'blas-openblas: eigenanalysis support, openBLAS version')
source=("${pkgname}::git+https://public.gitlab.polimi.it/DAER/mbdyn.git#branch=develop")
+install=mbdyn.install
sha256sums=('SKIP')
# Note: edit the list of modules to suit your needs
@@ -26,26 +29,38 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/mbdyn-utils-aur.patch"
sh bootstrap.sh
CXXFLAGS="-O3 -march=native" \
- FCFLAGS="-O3" \
- CFLAGS="-O3 -march=native" \
- ./configure \
- --with-module="${_modules}" \
- --prefix=/usr \
- --with-y12=no \
- --with-lapack=yes \
- --enable-python \
- --enable-Werror=no \
- --with-superlu=no
+ FCFLAGS="-O3" \
+ CFLAGS="-O3 -march=native" \
+ ./configure \
+ --with-module="${_modules}" \
+ --prefix=/usr \
+ --with-y12=no \
+ --with-lapack=yes \
+ --enable-python \
+ --enable-Werror=no \
+ --with-superlu=no \
+ --enable-runtime-loading \
+ --libexecdir=/usr/lib/${pkgname::}
+ perl -p -i -e 's#^(\s*libfile=")(\$libdir/)#$1\$DESTDIR$2#' libtool
+ perl -p -i -e 's#^(\s*if test "X\$destdir" = "X)(\$libdir")#$1\$DESTDIR$2#' libtool
+ cd ${srcdir}/${pkgname}/modules
+ perl -p -i -e 's#^(\s*libfile=")(\$libdir/)#$1\$DESTDIR$2#' libtool
+ perl -p -i -e 's#^(\s*if test "X\$destdir" = "X)(\$libdir")#$1\$DESTDIR$2#' libtool
}
build() {
cd ${srcdir}/${pkgname}
- make -j$(nproc)
+ make -j$(nproc) all
}
package() {
cd ${srcdir}/${pkgname}
- make install
+ mkdir -p "${pkgdir}/usr/lib/${pkgname::-4}"
+ libtool --finish "${pkgdir}/usr/lib/${pkgname::-4}"
+ make DESTDIR=${pkgdir} install
}
+sha256sums=('SKIP'
+ 'fd547a306e80db6fa298691dc866057554295cc29080e3454903b0526c7ed1c0')