summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvenom2021-01-06 14:54:56 -0800
committervenom2021-01-06 14:54:56 -0800
commite69f972a6dd2237c22c490e285825bda526f85f4 (patch)
tree4c091b684bea0cfd198fed585a974665d26c5913 /PKGBUILD
downloadaur-e69f972a6dd2237c22c490e285825bda526f85f4.tar.gz
create package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cea21873445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: EatMyVenom <eat.my.venomm@gmail.com>
+
+_modname=malilib
+_mcver="1.16.4"
+pkgname=mc-malilib-116-fabric
+pkgver="0.10.0.dev.21.arne.2"
+pkgrel=1
+pkgdesc="Library mod containing shared code for masas client-side mods."
+arch=('any')
+url="https://masa.dy.fi/mcmods/client_mods/"
+license=('LGPL')
+makedepends=('wget')
+source=("manifest.json::https://masa.dy.fi/api/games/mods/minecraft/latest/client/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd $srcdir
+ cat manifest.json | jq ".[\"mods\"][\"${_mcver}\"][\"fabric\"][\"${_modname}\"][\"version\"]" | sed 's/-/./g;s/+/./g'
+}
+
+build() {
+ wget $(cat manifest.json | jq -r ".[\"mods\"][\"${_mcver}\"][\"fabric\"][\"${_modname}\"][\"url\"]")
+}
+
+package() {
+ install -d -m 755 "${pkgdir}/usr/share/minecraft"
+
+ cp $(cat manifest.json | jq -r ".[\"mods\"][\"${_mcver}\"][\"fabric\"][\"${_modname}\"][\"filename\"]") \
+ "${pkgdir}/usr/share/minecraft/${_modname}-${_mcver}.jar"
+}