summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGenerator2017-10-03 23:45:34 +0100
committerGenerator2017-10-03 23:45:34 +0100
commitd1e26e9b2b622253e58c63c8db31315023c8a659 (patch)
treeb0bd3c879363876442b8deed8a579a1a0bc31929 /PKGBUILD
parentc838d0be889e3442be24c60c4262824b8a1de0dd (diff)
downloadaur-d1e26e9b2b622253e58c63c8db31315023c8a659.tar.gz
update git changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5586643acf2..cb1a275cb641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=mconnect
pkgname=$_pkgname-git
-pkgver=305.3f3f373
+pkgver=309.332cadb
pkgrel=1
pkgdesc="KDE Connect protocol implementation in Vala/C"
arch=('i686' 'x86_64')
depends=('gtk3' 'libgee' 'gnutls' 'json-glib' 'libnotify')
-makedepends=('at-spi2-atk' 'git' 'vala' 'json-glib' 'glib2' 'gobject-introspection')
+makedepends=('at-spi2-atk' 'git' 'vala' 'json-glib' 'glib2' 'gobject-introspection' 'meson')
url="https://github.com/bboozzoo/mconnect"
license=('GPL2')
install=$pkgname.install
@@ -24,16 +24,16 @@ pkgver() {
prepare() {
cd "$_pkgname"
- autoreconf -if
+ mkdir build
}
build() {
- cd "$_pkgname"
- ./configure --prefix=/usr
- make
+ cd "$_pkgname/build"
+ meson --prefix=/usr/
+ ninja
}
package() {
- cd "$_pkgname"
- make prefix="$pkgdir/usr/" install
+ cd "$_pkgname/build"
+ DESTDIR="$pkgdir" ninja install
}