summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikolaos Bezirgiannis2015-07-06 20:32:27 +0200
committerNikolaos Bezirgiannis2015-07-06 20:32:27 +0200
commitf15d2bac8dcc9be865bbd60ce88f77c43cb1dbea (patch)
treea96e4a8655fd518fb482a99de36a9bf95d0d7216 /PKGBUILD
downloadaur-f15d2bac8dcc9be865bbd60ce88f77c43cb1dbea.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5de21679ca82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nikolaos Bezirgiannis <bezeria at gmail dot com>
+
+pkgname=mcrl2
+pkgver=201409.1
+pkgrel=1
+pkgdesc="A formal specification language with an associated toolset."
+arch=('i686' 'x86_64')
+depends=('boost' 'qt4' 'glu')
+makedepends=('cmake')
+url=('http://www.mcrl2.org')
+license=('custom')
+source=("http://mcrl2.org/download/release/$pkgname-$pkgver.tar.gz")
+md5sums=('32818c4111aa406033e865c30ac7862b')
+install='mcrl2.install'
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_RPATH=/usr/lib/mcrl2 .
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -P cmake_install.cmake
+
+ # install license
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE_1_0.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+}