summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoah Arcouette2022-03-24 02:55:07 -0600
committerNoah Arcouette2022-03-24 02:55:07 -0600
commit3e0c6703681f12623ca42812821078f48762017c (patch)
tree65e068b01cafd2e2de9b13ad056197f55b8b9194 /PKGBUILD
parent1dcbcf91d70a182e9f156f1d1930d140949d1753 (diff)
downloadaur-3e0c6703681f12623ca42812821078f48762017c.tar.gz
add style selector
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 32 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfd62ce5a54f..db364c74fe56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname="md-git"
-pkgver=1.12
+pkgver=1.15
pkgrel=1
pkgdesc="Simple MarkDown Reader"
@@ -34,8 +34,38 @@ pkgver () {
build () {
cd "md"
+ echo "1: Default"
+ echo "2: Desert"
+ echo "3: Doxy"
+ echo "4: Moon"
+ echo "5: TTY-Support ( Designed to work with TTY Session users )"
+
+ printf "Please Pick a Style?(1) "
+
+ read style_id
+
+ if [ -z $style_id ] || [ $style_id = "1" ]
+ then
+ Style=default
+ elif [ $style_id = "2" ]
+ then
+ Style=desert
+ elif [ $style_id = "3" ]
+ then
+ Style=doxy
+ elif [ $style_id = "4" ]
+ then
+ Style=moon
+ elif [ $style_id = "5" ]
+ then
+ Style=tty-support
+ else
+ echo "Error: $style_id is not an option"
+ exit 1
+ fi
+
make mk
- make build
+ make build STYLE=$Style
}
package() {