summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsaruman92023-10-31 18:57:24 +0400
committersaruman92023-10-31 18:57:24 +0400
commit954351317ca21e2ea6aaeaa81345c1f85c8addeb (patch)
treeb7c6001c609a6d4e9c2c9f60a6fab08e478e0f22 /PKGBUILD
parent71249d3e1395a58d20eb3380c02486632ebff6ae (diff)
downloadaur-meanalyzer-git.tar.gz
Upgrade pkgver, set custom license, install new dat file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 325a134c75f3..1c212418d6c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
# Maintainer: Alex Sarum <rum.274.4 at gmail dot com>
+# Contributor: Misaka13514 <Misaka13514 at gmail dot com>
# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
# Contributor: Bailey Fox <bfox200012@gmail.com>
# Contributor: Tony Lambiris <tony@libpcap.net>
-pkgname=meanalyzer-git
-pkgver=1.282.0.r295.r0.g5f7ae54
+_pkgname=meanalyzer
+pkgname=${_pkgname}-git
+pkgver=1.283.3.r336.r0.g9c6f2a89
pkgrel=1
pkgdesc='Intel Management Engine firmware analysis tool'
arch=('any')
url='https://github.com/platomav/MEAnalyzer'
_branch='master'
-license=('GPL3')
+license=('custom')
depends=('python-colorama' 'python-crccheck' 'python-pltable')
makedepends=('dos2unix' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
source=("${pkgname}::git+${url}#branch=${_branch}")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "%s.%s.%s" \
+ "$(sed -n 's/.*ME Analyzer v\([0-9]\+\.[0-9]\+\.[0-9]\+\).*/\1/p' MEA.py)" \
+ "$(sed -n 's/.*Revision \(r[0-9]\+\).*/\1/p' MEA.dat)" \
+ "$(git describe --long --tags | sed 's/.*\([^-]*[0-9]\+-g.*\)/r\1/;s/-/./g')"
}
prepare() {
@@ -28,10 +35,14 @@ prepare() {
package() {
cd "${srcdir}/${pkgname}"
- install -Dm644 MEA.dat "${pkgdir}"/usr/lib/meanalyzer/MEA.dat
- install -Dm644 Huffman.dat "${pkgdir}"/usr/lib/meanalyzer/Huffman.dat
- install -Dm755 MEA.py "${pkgdir}"/usr/lib/meanalyzer/MEA.py
+ install -Dm644 MEA.dat "${pkgdir}"/usr/lib/${_pkgname}/MEA.dat
+ install -Dm644 Huffman.dat "${pkgdir}"/usr/lib/${_pkgname}/Huffman.dat
+ install -Dm644 FileTable.dat "${pkgdir}"/usr/lib/${_pkgname}/FileTable.dat
+ install -Dm755 MEA.py "${pkgdir}"/usr/lib/${_pkgname}/MEA.py
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
+ install -Dm644 README.md "${pkgdir}"/usr/share/doc/${_pkgname}/README.md
install -dm755 "${pkgdir}"/usr/bin
- ln -s /usr/lib/meanalyzer/MEA.py "${pkgdir}"/usr/bin/meanalyzer
+ ln -s /usr/lib/${_pkgname}/MEA.py "${pkgdir}"/usr/bin/${_pkgname}
}