summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-01-11 18:02:10 +0100
committerNarrat2020-01-11 18:02:10 +0100
commit4d70324ed5ccfe011aebbd34d2cee56e34a79157 (patch)
treeb26f70b39bf50d394c439d15c2679904aef82b42 /PKGBUILD
parente956f19d8e0b35af5b59c5c344162cd9adc70beb (diff)
downloadaur-4d70324ed5ccfe011aebbd34d2cee56e34a79157.tar.gz
update to 1.1.1
With this release the patches for the broken-status and the glib includes are obsolete See: https://github.com/obriencj/meanwhile/commit/c49837f276202ede0c8afcc9151f3054663091ad https://github.com/obriencj/meanwhile/commit/b2db429b554e6167c4762da6843b28d186d1d96a fix_groupchat remains und still applies. But dunno if really needed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c489828faae5..7b5d7355a37c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Troy C < rstrox -ta yahoo -tod com >
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Troy C < rstrox -ta yahoo -tod com >
# Contributor: Marek Skrobacki <skrobul@skrobul.com>
# Contributor: Alasdair Haswell <ali at arhaswell dot co dot uk>
pkgname=meanwhile
-pkgver=1.0.2
-pkgrel=9
+pkgver=1.1.1
+pkgrel=1
pkgdesc="Meanwhile libraries"
arch=('i686' 'x86_64')
-license=('GPL')
+url="https://github.com/obriencj/meanwhile"
+license=('LGPL3')
depends=('glib2')
conflicts=('meanwhile-svn')
-source=(http://downloads.sourceforge.net/sourceforge/meanwhile/$pkgname-$pkgver.tar.gz
- broken-status.patch
- fix_glib_includes.patch
- fix_groupchat.patch)
-sha256sums=('38a8059eaa549cbcb45ca0a5b453e9608ceadab360db2ae14581fb22ddabdf23'
- '9a60e2ca35d902d5dd9647254a20099ceb399a025f1b04c2676f90ffe2d276f0'
- 'c3dc0e423f7f4ceee65e4c08c1daebee23c61c608b970185074d118ed0199c47'
- '04aabfbcda84a8de9369aee330e6663c2237e038b949bb5142e58b4a11540445')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/obriencj/meanwhile/archive/v${pkgver}.tar.gz
+ fix_groupchat.patch)
+sha256sums=('10de306f03897572b30ce68ca80dffd04ec218f6842bbe0a47bb8cce933698d0'
+ '54d0faa5702e3b89be2a4fe994cfb2c373f409add3ba6b340a06f183c7446b21')
-build() {
- cd $srcdir/$pkgname-$pkgver/src
- patch -Np0 -i "${srcdir}/broken-status.patch"
- patch -Np2 -i "${srcdir}/fix_glib_includes.patch"
+prepare() {
+ cd "$pkgname-$pkgver/src"
patch -Np2 -i "${srcdir}/fix_groupchat.patch"
+}
- cd $srcdir/$pkgname-$pkgver
+build() {
+ cd "$pkgname-$pkgver"
CFLAGS="-mtune=generic -pipe -fstack-protector --param=ssp-buffer-size=4"
CXXFLAGS="${CFLAGS}"
@@ -37,6 +35,6 @@ build() {
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$pkgname-$pkgver"
make DESTDIR=$pkgdir install
}