summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-02-25 02:03:56 +0100
committersL1pKn072022-02-25 02:03:56 +0100
commit85620592b56f0d8889a20c163ac3130c94e301eb (patch)
treed44b23f2d0d015e94c8ea321f792fb5d283fd237 /PKGBUILD
parent0847ab598f55592d68ead3811161d05d9afb55e5 (diff)
downloadaur-med-openmpi.tar.gz
rework
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD98
1 files changed, 65 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91cea11be630..bd81df98c2c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,98 @@
-# Maintainer: nim65s
-# Former Maintainer: Joey Dumont <joey.dumont@gmail.com>
-# Contributor: simonp
-# Contributor: Martin Ortbauer <mortbauer@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
# Original: Michele Mocciola <mickele>
# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
-# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
+# Contributor: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
# Contributor: valandil
+# Contributor: nim65s
+# Contributor: Joey Dumont <joey.dumont@gmail.com>
+# Contributor: simonp
+# Contributor: Martin Ortbauer <mortbauer@gmail.com>
_pkgname='med'
-pkgname=('med-openmpi' 'med-openmpi-docs')
+pkgname=('med-openmpi'
+ 'med-openmpi-docs'
+ )
pkgver=4.1.0
-pkgrel=1
-pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5"
+pkgrel=2
+pkgdesc="Generic pre- and post-processing platform for numerical simulation (openmpi version)"
url="https://www.salome-platform.org/downloads"
license=('LGPL')
-depends=('hdf5-openmpi' 'tk' 'python')
-makedepends=('gcc-fortran' 'swig' 'openmpi' 'cmake')
+depends=('hdf5-openmpi'
+ 'tk'
+ 'python'
+ )
+makedepends=('gcc-fortran'
+ 'swig'
+ 'openmpi'
+ 'cmake'
+ )
arch=('x86_64')
source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz"
- "https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch")
+ 'hdf5-1.12.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/sci-libs/med/files/med-4.1.0-0003-build-against-hdf5-1.12.patch?id=350ea3e89d0e87e35a3a4b5f2ce92b55aae9d226'
+ )
sha256sums=('847db5d6fbc9ce6924cb4aea86362812c9a5ef6b9684377e4dd6879627651fce'
- '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206')
+ '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206'
+ )
+options=('debug')
prepare() {
- cd ${_pkgname}-${pkgver}
- patch -p1 -i "$srcdir/hdf5-1.12.patch"
- sed -i 's/if H5_VERS_MINOR > 10/if 0/g' src/ci/MEDfileCompatibility.c
+ patch -d "${_pkgname}-${pkgver}" -p1 -i "${srcdir}/hdf5-1.12.patch"
+ sed 's/if H5_VERS_MINOR > 10/if 0/g' -i "${_pkgname}-${pkgver}/src/ci/MEDfileCompatibility.c"
+ # set libdir as cmake install path instead of share
+ sed 's|share/cmake|lib${LIB_SUFFIX}/cmake|g' -i "${_pkgname}-${pkgver}/CMakeLists.txt"
}
build() {
- cd ${_pkgname}-${pkgver}
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DMEDFILE_USE_MPI=ON -DMEDFILE_BUILD_PYTHON=ON -DMEDFILE_BUILD_TESTS=OFF .
- make
+ CXX="mpicxx" \
+ CC="mpicc" \
+ FC="mpif90" \
+ F9X="mpif90" \
+ CFLAGS+=" -DH5_USE_18_API" \
+ cmake -S "${_pkgname}-${pkgver}" -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMEDFILE_USE_MPI=ON \
+ -DMEDFILE_BUILD_PYTHON=ON \
+ -DMEDFILE_BUILD_TESTS=ON \
+ -DMEDFILE_INSTALL_DOC=ON \
+ -DCMAKE_SKIP_RPATH=ON
+
+ cmake --build build
}
-# I got 37 tests failed out of 91…
-#check() {
- #cd "$pkgname-$pkgver"
- #make test
-#}
+check() {
+ cd build
+ LD_LIBRARY_PATH="${srcdir}/build/src" \
+ ctest -E '._Python' --output-on-failure # exclude python test due circular dependency(?)
+}
package_med-openmpi() {
provides=('med')
conflicts=('med')
replaces=('med')
- cd ${_pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ DESTDIR="${pkgdir}" cmake --build build --target install
- rm -rf $pkgdir/usr/share/doc
+ # remove docs
+ rm -rf "${pkgdir}/usr/share"
+ # remove testsuit
+ rm -fr "${pkgdir}/usr/bin/"test*
+ # create missing symlinks (see install output)
+ (cd "${pkgdir}/usr/bin"
+ ln -sf mdump4 mdump
+ ln -sf xmdump4 xmdump
+ )
}
package_med-openmpi-docs() {
+ pkgdesc+=" (Documentation)"
arch=('any')
depends=()
- cd ${_pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ DESTDIR="${pkgdir}" cmake --build build --target install
- rm -rf $pkgdir/usr/share/cmake
- rm -rf $pkgdir/usr/lib
- rm -rf $pkgdir/usr/include
- rm -rf $pkgdir/usr/bin
+ # remove headers, binaries and libraries
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/bin"
+ rm -rf "${pkgdir}/usr/lib"
}