summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichele Mocciola2016-11-17 19:16:33 +0100
committerMichele Mocciola2016-11-17 19:16:33 +0100
commit0ec22ed56456e347c12fd8ccdfe16e25753291d7 (patch)
tree719e15602764f677dafb789aae3a2ce09e1c064e /PKGBUILD
parent8743ee77ba8f8078edf91b29e871f3367a3d68d6 (diff)
downloadaur-0ec22ed56456e347c12fd8ccdfe16e25753291d7.tar.gz
Updated to version 3.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6854064d4ddb..ae12688c545e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=med-salome
_pkgname=med
-pkgver=3.1.0
-pkgrel=3
+pkgver=3.2.0
+pkgrel=1
pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64"
url="http://www.code-aster.org/outils/med/"
license=('LGPL')
-depends=('hdf5-1.8' 'python2')
+depends=('hdf5' 'python2')
makedepends=('gcc-fortran' 'coreutils' 'swig')
optdepends=('tk')
provides=("med={pkgver}")
@@ -22,7 +22,13 @@ arch=('i686' 'x86_64')
source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz"
"patch-include_2.3.6_med.h.in"
"patch-include_med.h.in"
- "patch-src_2.3.6_ci_MEDequivInfo.c")
+ "patch-src_2.3.6_ci_MEDequivInfo.c"
+ "patch-int2long")
+md5sums=('eb61df92f0624feb6328f517cd756a23'
+ 'b83949326d7ae0ca77a06822b754a329'
+ '14a151cea108388d7a3b4c62887169f6'
+ '8f0cbf6f08783a6ba68ff5ab240dd62e'
+ '08c436aee7cf573ff28463cc2e88ec1b')
# _installdir=/opt/${pkgname}
@@ -30,7 +36,7 @@ _installdir=/usr
_sharedir=${_installdir}/share/${pkgname}
prepare() {
- cd ${srcdir}/${_pkgname}-${pkgver}_SRC
+ cd ${srcdir}/${_pkgname}-${pkgver}
# patch H5public_extract.h.in
sed -i -e '/^#typedef/ s/#/\/\//' ./include/H5public_extract.h.in
@@ -39,21 +45,26 @@ prepare() {
patch -p0 < ${srcdir}/patch-include_2.3.6_med.h.in
patch -p0 < ${srcdir}/patch-include_med.h.in
patch -p0 < ${srcdir}/patch-src_2.3.6_ci_MEDequivInfo.c
+ patch -p0 < ${srcdir}/patch-int2long
}
build() {
+ export FFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
+ export FCFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
+ export F77=gfortran
+ export FC=gfortran
export PYTHON="$(which python2)"
- cd ${srcdir}/${_pkgname}-${pkgver}_SRC
+ cd ${srcdir}/${_pkgname}-${pkgver}
- ./configure --with-f90=gfortran --prefix=${_installdir} --with-med_int=int --datadir=${_sharedir} --with-swig=yes --with-hdf5=/opt/hdf5-1.8
+ ./configure --with-f90=gfortran --prefix=${_installdir} --with-med_int=int --datadir=${_sharedir} --with-swig=yes
make
}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}_SRC
+ cd ${srcdir}/${_pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
# now move the testprograms to share, we don't want all the stuff in the bindir
cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testc ${pkgdir}${_sharedir}/testc
@@ -62,8 +73,3 @@ package() {
cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/usescases ${pkgdir}${_sharedir}
rm -r ${pkgdir}/usr/bin/{usescases,unittests,testf,testc}
}
-
-md5sums=('a1e1eb068f20634f5ea797914241eb51'
- 'b83949326d7ae0ca77a06822b754a329'
- '14a151cea108388d7a3b4c62887169f6'
- '8f0cbf6f08783a6ba68ff5ab240dd62e')