summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya2016-10-31 16:23:01 +0100
committerIsmaël Bouya2016-10-31 16:23:01 +0100
commitc40530348cf59e36cfe6c7c256e514a727a7003c (patch)
tree9972ee52ee76a2793a50d0d96c7291feee7d9688 /PKGBUILD
parentda0ff23d6449cc6baa4fafdd1d44c3f120357b97 (diff)
downloadaur-c40530348cf59e36cfe6c7c256e514a727a7003c.tar.gz
Python3 si now officially supported
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcdfca66f7de..fa7b9b617def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=mediagoblin
pkgver=0.9.0
-pkgrel=3
+pkgrel=4
pkgdesc='A free software media publishing platform'
arch=('i686' 'x86_64')
url='http://mediagoblin.org'
license=('AGPL')
provides=('mediagoblin')
conflicts=('mediagoblin-git')
-depends=('python2' 'python2-lxml' 'sqlite' 'python2-pillow' 'python2-virtualenv' 'npm' 'nodejs')
+depends=('python' 'python-lxml' 'sqlite' 'python-pillow' 'python-virtualenv' 'npm' 'nodejs')
optdepends=(
'postgresql: to use the postgresql database backend'
- 'python2-psycopg2: to use the postgresql database backend'
- 'python2-gobject: to handle videos'
+ 'python-psycopg2: to use the postgresql database backend'
+ 'python-gobject: to handle videos'
'gst-libav: to handle videos'
- 'gst-python2: to handle videos'
+ 'gst-python: to handle videos'
'gst-plugins-good: to handle videos'
'gst-plugins-bad: to handle videos'
'gst-plugins-ugly: to handle videos'
@@ -48,7 +48,7 @@ build() {
cd "$srcdir/mediagoblin"
./bootstrap.sh
- ./configure
+ ./configure --with-python3
make || make
./bin/easy_install flup
}