summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2017-11-14 07:36:32 -0200
committerLucas Heitzmann Gabrielli2017-11-14 07:36:32 -0200
commit4aefc8ff693c80862d317b45c2c46257c21e01ed (patch)
tree7f6f5c0de5e45ffbfe4beafd5a3e5c6ca1169290 /PKGBUILD
downloadaur-4aefc8ff693c80862d317b45c2c46257c21e01ed.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9573b2423f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+pkgname=meep-git
+pkgver=1.3.r95.ga5669c1
+pkgrel=1
+pkgdesc='Free finite-difference time-domain (FDTD) software for electromagnetic simulations'
+arch=('i686' 'x86_64')
+url='https://github.com/stevengj/meep'
+license=('GPL2')
+depends=('harminv' 'libctl' 'hdf5' 'gsl' 'fftw' 'openmpi' 'swig' 'python-numpy')
+makedepends=('gcc-fortran' 'suitesparse')
+optdepends=('h5utils: visualization and conversion of scientific data'
+ 'python-mpi4py: use MPI from the python interface'
+ 'mpb: calculation of electromagnetic modes')
+options=('!libtool' '!makeflags')
+provides=('meep')
+conflicts=('meep')
+source=('git+https://github.com/stevengj/meep.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/meep"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/meep"
+ sed -i '/unknown argument/d' autogen.sh
+ ./autogen.sh --prefix=/usr --enable-shared --with-mpi --with-python
+ make
+ sed -i -e "s/__name__\.rpartition.*/__name__/" python/__init__.py
+}
+
+package() {
+ cd "${srcdir}/meep"
+ make DESTDIR="$pkgdir" install
+}