summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciej Dems2021-10-14 08:07:42 +0200
committerMaciej Dems2021-10-14 08:11:38 +0200
commit59401acf4445b6e944c2c516118fba4d3ca5906d (patch)
tree4ccec02b8823b8c5de5a1d349713c1f61db86067 /PKGBUILD
parent16d90497de092695cdf068a685e6ed2ced2c2e13 (diff)
downloadaur-59401acf4445b6e944c2c516118fba4d3ca5906d.tar.gz
Python dependencies optional
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11806a89c973..bc943ac98b16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,17 @@
pkgname=meep-python
pkgver=1.21.0
-pkgrel=1
+pkgrel=2
pkgdesc="A free finite-difference time-domain simulation software package (with Python support)"
arch=('x86_64')
url="http://ab-initio.mit.edu/wiki/index.php/Meep"
license=('GPL')
-depends=('openmpi' 'harminv' 'libctl' 'hdf5' 'gsl' 'fftw' 'guile' 'julia' 'mpb' 'python' 'python-numpy' 'python-scipy' 'python-matplotlib')
+depends=('openmpi' 'harminv' 'libctl' 'hdf5' 'gsl' 'fftw' 'guile' 'julia' 'mpb' 'python' 'python-numpy')
makedepends=('gcc-fortran' 'suitesparse' 'swig')
-optdepends=('h5utils: for visualization and conversion of scientific data')
+optdepends=('h5utils: for visualization and conversion of scientific data'
+ 'python-matplotlib: for visualization in Python'
+ 'python-scipy: for scientific computations in Python'
+ 'python-autograd: for fast differentiation in Python')
options=('!libtool' '!makeflags' 'staticlibs')
conflicts=('meep')
source=("meep-$pkgver.tar.gz::https://github.com/NanoComp/meep/archive/v$pkgver.tar.gz")